Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

problem with webcam publisher

SreejaVirtus
Level 2
Level 2

hi there,

       Webcam publisher displaying in mozilla  but not in chrome or ie.i had tried private stream example but also having the same issue.

      Any help would be greatly appreciated.

Thanks in advance,

Sreeja

0 Replies
Hinne
Level 3
Level 3

I just tried my app in chrome too and my complexObject collectionNode didn´t work, my chat model worked fine though. video didn´t seem to work either. My collectionNode seemed to init fine and sends/receives the first item but than hangs.

I dumped my trace() calls into a TextField. But now everything works! This is strange since I only changed my trace() calls

When I switch back to regular trace() calls the problem comes back.

Hinne
Level 3
Level 3

Sreeja, the good news: everything works in chrome.
the bad news: there is something related to chrome causing hang-ups. I have even seen the flash player crash in chrome.

did you try the debug version of flash player?

just for curiosity, can you try rename your trace() calls to some dummy function that does nothing?

henry

SreejaVirtus
Level 2
Level 2

Hi there,

             Sorry for my repeated queries. I m using debug version of flash player only.

             I have a little confusion with ur suggestion [rename your trace() calls to some dummy function ].Does it mean tracing any funtion return value or text input? i done the same but again the same issue.

Thanks in advance.

Regards,

Sreeja

Hinne
Level 3
Level 3

I replaced my trace() with

        private function debug(s:String):void
        {
            if (DEBUG) {
                debugTrace.post(s);
            } else {
                trace(s);
            }
        }

debugTrace is my scrollable TextField class so I can see my traces online.

did you try other browsers?

did you fully debug your code?

SreejaVirtus
Level 2
Level 2

Hi henn,

Now its working fine.Thanks a lot for your service.