Issue with Server Integration using PHP. Says "bad-response"

Avatar

Avatar

TK_Radion

Avatar

TK_Radion

TK_Radion

25-10-2011

Hi,

Using PHP 5.2.5 and LCCS.php revision #2 for server integration.

Have followed code from sample application, but it gives error when trying to initiate object for RTCAccount.

This is what I get when trying with Command Prompt:

C:\wamp\bin\php\php5.2.5>php C:\wamp\www\radion_php\lccs\lccs.php --debug --host=http://collaboration.adobelivecycle.com cprovider USER_NAME PASSWORD

$Revision: #2 $ - $Date: 2011/07/20 $

http_get: http://collaboration.adobelivecycle.com/cprovider?mode=xml&accountonly

=true&

Array

(

    [0] => HTTP/1.1 302 Moved Temporarily

    [1] => Server: Apache-Coyote/1.1

    [2] => X-Powered-By: Servlet 2.4; JBoss-4.2.1.GA (build: SVNTag=JBoss_4_2_1_

GA date=200707131605)/Tomcat-5.5

    [3] => Expires: Tue, 25 Oct 2011 09:29:17 GMT

    [4] => Cache-Control: max-age=30

    [5] => Set-Cookie: Whitcomb-Ident=cprovider:na2-sdk-a757f7e0-6ecf-450a-8959-

3c08b63fdb84; Domain=collaboration.adobelivecycle.com; Path=/cprovider

    [6] => Location: https://na2.collaboration.adobelivecycle.com/cprovider?mode

=xml&accountonly=true&

    [7] => Content-Language: en-US

    [8] => Content-Length: 0

    [9] => Date: Tue, 25 Oct 2011 09:28:47 GMT

    [10] => Connection: close

)

Error: exception 'RTCError' with message 'bad-response' in C:\wamp\www\radion_php\lccs\lccs.php:674

Stack trace:

#0 C:\wamp\www\radion_php\lccs\lccs.php(255): RTCAccount->do_initialize()

#1 C:\wamp\www\radion_php\lccs\lccs.php(1047): RTCAccount->__construct('http://collabor...')

#2 {main}

C:\wamp\bin\php\php5.2.5>

Not sure if I am missing something.

Please help..

Thanks

View Entire Topic

Avatar

Avatar

nzezelj

Avatar

nzezelj

nzezelj

25-10-2011

Hi Tilak,

Ensure you are using the latest LCCS.php file.  There was a recent thread on it (http://forums.adobe.com/message/3975633#3975633), to which I attached the latest revision file.

Other than that, I am not sure why your code throws the RTC.  I just tried it and it worked for me with PHP 5.3.8.

Try with the latest LCCS.php and let us know how it goes.

Thanks,

Nikola