Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Hours calculation

Avatar

Level 1

Dear all

I've a problem to create the script to calculate the total hours of travel and work.

I've tried to send an e-mail to address liveCycle8@gmail.com with the form that I'm looking to creat

I hope the address is correct

I've one problem like I found in this forum

I try to explain better and enclosed my form.

This is the first question that I sent to a wrong forum

During the creation of some calculation form, I've apropble to calculate the total time in hour because if I insert for example

4 time 0.15 min the total should be 1 hour but the form write 0,60.

Can some one help me to set the script for have the correct visualization in hours ?

And this is the second explanation

I'm using CycleDesigne ES, and I try to explain better what I need, sorry in advance for my bad english

Today I've a day off and I can't enclosed image or the correct setting for the fields

What I need is to create some field to calculate the travel time and travel wrok for single or multiple days

Hours Travel from | Hours travel to | work in the morning | finish work in the morning | start work in the afternoom | finish travel afte

So for example the technician start is travel at 8.00 and arrive at 8.15 start work at 8,15 and finish at 12.30 start work at 13,30 and finish at 18.00 start travel at 18.00 and arrive at 18,15.

We calculate minimum 15 minutes, we never write 8,20

Suppose that the label are

VS1 = start travel

VA1 = travel arrive

VSR = start travel back

VAR = Travel arrive back

The same procedure is for the work in the morning and in the afternoon

If the sum of VS1 and VA1 is 15 and is the same for VRS and VAR the total is 0.30 and is correct but if I try to calculate the sum ot two days the sum is 0.60 and should be 1 hour

The following is what I looking to do

Giorno

Ore di viaggio andataTravel time to site

Ore di  lavoro mattinoWork time morning

Ore di  lavoro pomeriggioWork time afternoon

Ore di viaggio ritornoReturn travel time

Totale ore viaggio

Totale ore di lavoro

Day

dalle/from

alle/to

dalle/from

alle/to

dalle/from

alle/to

dalle/from

alle/to

Total travel time

Total work time

1

2

3

4

The calculation in Excel is

=SE((B19<>"")*(C19<>"")+(H19<>"")*(I19<>"");(I19-H19)+(C19-B19);"")

1 Reply

Avatar

Level 1

Hi

Can someone please analize my request ?

Or give an aswer ?

Thank you