Expand my Community achievements bar.

Learn about Edge Delivery Services in upcoming GEM session

Form XDP data missing

Avatar

Level 2

I created a form, I can fill it, submit it via my workspace, but once I go to review it (2nd step in my process, which is a simple transfer of the form information to another user), when I open the form it's empty, like when I open the form for the first time.

When I record the process, I can see that the data is received by the server and I see the data from my form. But, when I get to the 2nd step, my xdp is clear like a new file.

I don't see anything that could remove the data in my process. Could someone tell me if there's some place where that data could be erased?

P.S.: I'm using LiveCycle ES2.

12 Replies

Avatar

Former Community Member

Hi, I have two questions:

1. What are you using to view the PDF - Acrobat or Reader?

2. If you are using reader, has the PDF been reader enabled?

Avatar

Level 2

1. I'm using the Reader

2. No

But isn't using the LiveCycle Workspace with the Reader suppose to work even if it's not reader enabled?

Avatar

Former Community Member

Livecycle Forms Designer is used to create a PDF. You use Acrobat and Reader to view and fill in the PDF. If you use Acrobat, the form data is saved when the form is re-opened. With Reader it is not, unless the form is Reader Enabled but there is an additional cost in doing that. So that is the reason your data is not being preserved when the form is reopened

Avatar

Level 2

I tought using the LiveCycle Workspace in LiveCycle ES2 was supposed to make the saving of forms possible whatever software you are using. Could someone confirm (or deny) that you need to reader enable the forms to save them via the LiveCycle Workspace?

Also, I can see the data being sent to the server when I hit complete the first time.

Avatar

Former Community Member

If you want to save loccally on your own computer then the form must be Reader Extended for that. Workspace

gives you the ability to save the form but you are submitting it (the data)  to the server and it is being stored there. You do not need Reader Extensions for that. When you require the form again teh data and form are recombined and rendered in real time.

Paul

Avatar

Former Community Member

I assume you are using LC 8.2.1 .....on the user step in the Form Data Mappings

are you suing the same variable as input and output?

Are you using the same form throughout or changing it?

Paul

Avatar

Level 2

Well I am using LC 9.0.0 and I am using the same variable as input and output for my user step. The data gets to the user step, since I can put information comming from the form (via the xdp) in my "task instructions".

Avatar

Former Community Member

Ok can you create an LCA file and post it so I can see what is happening?

Paul

Avatar

Level 2

Here's the file. The xml file for the data is not the best, I'm trying to get lists whitout success, but it should at least get the first row of the dynamic table I have in the form.

Thanks for taking a look.

Georges

Avatar

Former Community Member

Just wanted to give you an update on this. I am able to reproduce the issue and have narrowed it down to a probklem with the form. If I create a new form from your schema then the data flows through just fine. I will continue to investigate and let you know when I find something.

Paul

Avatar

Former Community Member

I have been playing with the structure of the form....If I remove the Consultant Name from the table then it sets the data just fine. I do not know why this is an issue. If I save the data from the form then remerge it after it works fine.

You will have to open an incident with support if you want to take this further.

Paul

Avatar

Level 2

I have seen this issue if you are using the default renderer with an XDP.  If you save your file as a PDF and stay with the default renderer, things should start working.