Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Copy as table not working on protected documents

Avatar

Level 2

Does anyone know why users can no longer use the copy as table function when attempting to copy data from a protected PDF?

I have verified they have copy and modify permissions and still not working.

any help would be greatly appreciated

Thanks,

Chad

8 Replies

Avatar

Level 9

Chad

I'm not 100% familiar with how the "Copy as table" is supposed to behave, but I have done some testing and the "Copy as table" seems to be working for me. Can you explain what is happening in your environment?  Also, what versions of Rights Management and Reader or Acrobat are you using?

Steve

Avatar

Level 2

Hi Steve,

We are using

Livecycle

Version: 9.0.0.0, GM Patch Version: SP1 Service Pack Version: 9.0.0.1.20100511.1.236952

Using acrobat 9 Pro to view the doucment.

When we highlight a table right click and choose copy as table the progress bar pops up and seems like it is working but when we go to paste in excel for example it doesn't even give us the paste option.  Note right clicking using copy and pasting into excel works but of course is unformatted.

Let me know if you requrie any further details.

thanks,


Chad

Avatar

Level 9

Chad

Can you post an unprotected (no policy) copy of the PDF document you are using so I can test with it?

Thanks

Steve

Avatar

Level 2

I can't post it here on an open form but could send it to you via email or to a secure site as we do have an NDA with Adobe.

Avatar

Level 9

Chad

I sent you a private message with an e-mail the you can send the document to.

Thanks

Steve

Avatar

Level 9

Chad

I received the files and did some testing.  I believe the problem is related to the fact that the PDF has a watermark.  Here is what I discovered... 

Test 1

I opened the PDF that had had the policy removed, this PDF had a watermark

I performed a "Copy As Table"

I attempted to paste the content into an Excel 2007 spreadsheet

The content WAS NOT copied (this duplicates the behaviour you reported)

Test 2

I opened the PDF that had never had a policy applied to it, this pfd DID NOT have a watermark

I performed a "Copy As Table"

I attempted to paste the content into an Excel 2007 spreadsheet

The content WAS pasted into the spreadsheet properly

Test 3

I opened the PDF that had never had a policy applied to it, this pfd DID NOT have a watermark

I applied my own RM policy to the document (with the copy permission enabled)

I saved the document

I opened (and authenticated) to the document

I performed a "Copy As Table"

I attempted to paste the content into an Excel 2007 spreadsheet

The content WAS pasted into the spreadsheet properly

Test 4

I opened the PDF that had had the policy removed, this PDF had a watermark

I removed the watermark (using Acrobat Pro 9.3.4)

I saved the document

I re-opened to the document

I performed a "Copy As Table"

I attempted to paste the content into an Excel 2007 spreadsheet

The content WAS pasted into the spreadsheet properly

So based on my tests, I believe the problem is related to the Watermark.  Please test on your end and let me know what you discover.
Thanks
Steve

Avatar

Level 2

Hi Steve,

I agree it is definately related to a watermark being applied on the document or not. When I tested here I created a new test policy with no watermark and had no problem - then added a watermark to the policy re-applied and then it no longer worked., removed re-applied and back to working again.

So we know the cause, any idea on a solution that will allow the copy as table while leaving the watermark?

Thanks again for your help on this.

Chad

Avatar

Level 9

Chad

Unfortunately, I don't know of anyway to get around that the watermark is causing.  I don't know if this is expected behaviour or a bug.  At this point I would recommend that you log this issue with Adobe technical support as they will be able to confirm and or log a bug.

Thanks

Steve