Expand my Community achievements bar.

Enhance your AEM Assets & Boost Your Development: [AEM Gems | June 19, 2024] Improving the Developer Experience with New APIs and Events

Check signature before submitting a form ?

Avatar

Level 2

Hi All,

Can some one help me out with this issue which seems quite easy but can not find how:

To block submitting a form before signing it, in other words make signature field required (which is not available within object properties) ?

And in case I have multiple signature fields and different people to sign, is there a proper way to do it ?

Please any idea would be appreciated !

Thanks a lot in advance.

5 Replies

Avatar

Level 6

Please check the thread to get the signature status. http://forums.adobe.com/message/2630235#2630235

Can get the status of any signature fields present on the form. Based on the status of multiple signature fields can allow/block the form from submitting.

Hope this helps.

Avatar

Level 2

Hi Raghu,

This code seems not working on Adobe LC V9 ES2

event.target.getField("form1[0].Page1[0].SignatureField1[0]");

var oState =getSigField.signatureValidate();

Is there may a new syntax for signatures fields for newer version of adobe lc?

Thanks in advance



Avatar

Level 6

did you replace the path which is highlighted in the below script block, to reflect the signature field you are using in the form?

If not replace the path  "form1[0].Page1[0].SignatureField1[0] - This is the complete path from the ROOT node of the form"  using the path of signature field you are using in the form.

----------------
var getSigField = event.target.getField("form1[0].Page1[0].SignatureField1[0]");
var oState =getSigField.signatureValidate();

// Get the current field's signed state.
if (oState == 0) {
    app.alert("Not Signed");
} else {
     app.alert("Document Signed");
}

----------------

Avatar

Level 2

Hi Raghu,

Yes I did that but i'm still having the error of: 'validateSignature is not a function'.

Since i have long paths, I have some issues with this (Usually i use the CTRL button + mouse click  to get field path) then i added [0] to each field name.  but still not working. I cannot figure out where the error is coming from !

Something else can be the origin of this error?

Thanks a lot Again.

Avatar

Level 6

I am unable to reproduce the error. will it be possible to share the form? if so please send me an email at raghu.nagireddy@gmail.com