Button accessibility - JAWS only reads "+" on button

jenin61939931 12-04-2017

Hi!

I'm creating a screen-reader accessible form, and was dismayed to realize that--for buttons--JAWS doesn't read anything but the button caption.

This is particularly devastating with the add/delete row buttons. I have set both the Tool Tip and Custom Screen Reader Text, and even defined the precedence, but JAWS still only reads caption, "+".  It needs to read "Add a new row below this one", etc.  As things stand, these buttons will be completely useless for my visually-impaired users.  Note: if you delete the button's caption and leave it visually-blank, then JAWS can read the tool tip/custom reader text.  But that's not helpful at all.

It looks like this was an issue as far back as 2010, which is mind-boggling to me. Does anyone know a workaround for this issue?

Note: I'd rather not do the "invisible button over the image" method, since that will make things more complicated with the buttons already being in a table.  I'm not sure I'll even be able to pull that one off.  Is there a way to force it with JavaScript, maybe?

Any help would be hugely appreciated, thanks!

JLN

Mark Solution

Are these answers useful?
Help other community members by marking useful answers as accepted.

Accepted Solutions (0)

Answers (2)

Answers (2)

jenin61939931 14-12-2017

No, it's amazing to me that this issue hasn't been resolved. Accessibility is so important.

However, you can use this workaround:

How to make submit button a custom image

One step is missing in this explanation--you also need to type the full button description into the "Tool Tip" field on the Accessibility tab. That will give JAWS the right description to read (and it works, once the button's caption is deleted!).

I was even able to do this in a table by wrapping a table cell in a Subform set to "position", and layering an invisible button over the top of a plus button image within that cell.

I'm still figuring out how to give the impression the button has been pushed on the click, though. I'll post that solution here if I find it.

Good luck!

JLN

akgrimes 14-12-2017

Did you find a solution? I have this exact issue -- and we're waaaaay down the road on deploying this new form. This is going to be a big problem if I can't resolve it.