Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

After ES4 upgrade, SSO not working. AssertionId is not set. Ideas?

sashmore
Level 2
Level 2

After (finally) successfully upgrading from ES2 to ES4 (out-of-place), I'm having trouble with SSO (Single-Sign-On).  I checked the settings for my domain and everything looks the same as it did on the old box.

I'm getting the following messages in server.log

When trying to open a protected file.

2013-05-14 13:12:34,713 WARN  [com.adobe.edc.server.platform.UMHelper] (http-0.0.0.0-8443-2) Thread: http-0.0.0.0-8443-2, hashcode: 566840686 AssertionId is not set. Trying to get it from Request Header

SSO fails, but after typing in credentials when prompted, the file opens.

2013-05-14 13:12:39,326 INFO  [org.apache.xml.security.signature.Reference] (http-0.0.0.0-8443-2) Verification successful for URI "#dfa926ae5c61c6a0a55b7e38ad8114f5"

Any ideas?

Thanks in advance.

0 Replies
Anonymous
Not applicable

Sashmore,

Do you see any errors in the server logs?

If yes, then please share the server logs.

Also tell us which OS+App Server+DB are you using for LiveCycle?

sashmore
Level 2
Level 2

Sorry, I was out of office. 

SSO is working now.  Not sure what happened. 

Thanks for the help!

Santosh_Nangunoori
Employee
Employee

Good to know that it is working fine now and Thanks sashmore for confirmation.

--Santosh