Expand my Community achievements bar.

Advanced Process Design using Adobe LiveCycle Workbench: Should I see an attachement in attachment tab?

Avatar

Level 2

HI,

   After I did Task 4 Step 7 to active "adding Attachment ", save and deploy, should I see an attachment in the attachments tab of WorkSpace once I click "Add Attachment" button of  HR_Request Form?

   I can see the attachments tab but can't see the attachment I add using the button "Add Attachment".  Is it correct?

   From source code of HR_Request Form, I can see the function "addAttachment" and "fileRef_select".

Best Regards

Mark Dong

5 Replies

Avatar

Level 10

You should see "Attachment(1)" for the title of the attachment tab.

Jasmin

Avatar

Level 2

I can't see new attachment.  I deployed new HR_Request.swf and can see Livecycle Related Information.  That means I already update new swf succesfully (uncomment the codes).

Will I wait for some time to see that after I add attachment? Or I can see immediately? My understanding it is a client behavior so I should be able to see immediately.  My image is running very slowly.

Avatar

Level 10

You should just have to wait a few seconds, and then see the attachment in there.

If your machine is slow it could take a few more seconds (depending the size of the attachment). It is a client side behavior.

I've put those fields there, just to show people what they can do client side from a Flex form. I didn't create an exercice associated with this since it's our MAX collateral and I was planning to just talk about it.

Jasmin

Avatar

Level 2

Hi,

  I got it.  Problem is caused by VMImage's ip address. I changed the network so that the IP address was changed as well.  But I did not reboot the image.  So it seems LC can't know the new ipaddress and always thrown some exception related with old ip address. Now I reboot the image and everything runs fine.

  From this scenario, I guess "Add attachment" will call backend system to inform "Attachment Tab" to add one attachment.  Otherwise, the ip address problem should not cause the problem

Best Regards

Mark Dong

page footer