Expand my Community achievements bar.

July 31st AEM Gems Webinar: Elevate your AEM development to master the integration of private GitHub repositories within AEM Cloud Manager.

1046: Type was not found or was not a compile-time constant: NetStreamInfo.

Avatar

Level 1

I'm getting started with LCCS (very powerful and quick service by the way - Adobe MAX session I attended was very impressive) and I'm following the tutorial videos to get excited enough to delve more into it... though while finishing up the first Movie Tutorial... I get this error:

Severity and Description Path Resource Location Creation Time Id

1046: Type was not found or was not a compile-time constant: NetStreamInfo. LCCS Unknown 1255756624024 3651

I'm using Flash Player 10 (no src).
7 Replies

Avatar

Level 1

Oups, sorry

Solved - If you get this error - Make sure you're Player is actually the 10.0.0 (Project (right click) >> Properties >> Flex Compiler >> require flash version: 10.0.0

Avatar

Former Community Member

Hi

I m facing the same problem and I have made the changes which u told but still the error isn't remove!!!

Is there any other possiblity due to which this error appears???

Avatar

Level 4

Thanks for coming back to post what you found, just saved me some time.

-Eric

Avatar

Level 2

I'm facing the same problem, but the setting you speak of isn't there in Flex Builder 3 Pro (or maybe it has something to do with the fact that I'm developing an AIR application?). Screenshot below.

Properties for LCCS Test 2.jpg

Avatar

Level 2

Just checked it, and indeed it's because it's an AIR application. Anyone know of another way to fix this?

Also tried to edit the .actionScriptProperties file residing in the project root folder, and changing the player version manually, unfortunately it didn't work. Closing/Opening the project and restarting Flex Builder didn't help.

Avatar

Former Community Member

NetStreamInfo is part of player 10, so you need to do couple of things in case you are using player 10 swc.

a) If you are using Flex Application, you need to make Project->Properties->Flex Compiler ->Require Flash player version as 10.0.0.0 in the Flex Builder

or

b) For Air Applications, you should Add "-target-player=10" to additional compiler arguements under properties->Flex Compiler

This will make sure you app compiles with player 10. Also, you should have the right Flex SDK that supports player 10. In your case, since its air app, go with step b) . There was a previous forum post on this

http://forums.adobe.com/message/1915708#1915708

Thanks

Hironmay Basu

Avatar

Former Community Member

The error disappeared when I changed Flex SDK version from 3.0.0 to 3.4.0.