Expand my Community achievements bar.

Radically easy to access on brand approved content for distribution and omnichannel performant delivery. AEM Assets Content Hub and Dynamic Media with OpenAPI capabilities is now GA.

Slow to Load Prepopulated PDF Form in Workspace

Avatar

Former Community Member
We experience that sometimes it takes a long time (abt 10-15 sec) to load a prepopulated PDF form in Workspace. This is not acceptable by our users. They expect that the prepopulated PDF form to be displayed below 5 sec.



FYI, we use customised Default Render service to prepopulate the data retrieved from multiple remote DB server (Oracle 8i and SQL Server 2005) into the PDF Form. In particular, we retrieved about 1500 rows of employee information (ID and name) from Oracle DB View to be populated into a dropdownlist in PDF Form.



Please find below the server and client machine spec:

SERVER:

IBM XSERIES_3650

Intel Xeon CPU 5160 @3.00 GHz

2.99 GHz, 4.00 GB of RAM

Windows Server 2003 SP1 Standard Ed



CLIENT:

512 MB of RAM

Windows XP Pro SP2

Adobe Reader 8

Adobe Flash Player 9

Internet Explorer 6



Does anyone can give us advice what to check/investigate to determine the root cause of the problem and how to improve the performance? Thanks.
4 Replies

Avatar

Former Community Member
First glance, it sounds like your query is what's really slowing you down.

Avatar

Former Community Member
At first, we also guessed that the 1500 rows query is the one which cause the slowing down. However, this is what we observe:



- Whenever the client machine is restarted, the time it takes to load and display LiveCycle ES Sample MortgageLoan-Prebuilt PDF form in Workspace will be slow (more than 10s). Subsequent try of loading the PDF form will be faster (2-3s)

- Whenever the client machine is restarted, the time it takes to load and display our prepopulated PDF form in Workspace will be slow (15-25s). Subsequent try of loading the PDF form will be faster (5-7s)

- In our custom Default Render process, we write trace message to server.log file at the start and end of the process. We noticed, the time it takes between the start and the end of the process is consistently about 2-5s which include retrieval of 1500 db records.



Please advice.

Avatar

Former Community Member
the first time is always going to be slow,can you mail me @ mergeandfuse@gmail.com

Avatar

Former Community Member

We are having similar situation with LiveCycle ES3 Workspace. Could you share the experience on how to solve this issue?

Thank you!