Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

RunTime Error and Xml Source

_jerome_dinnat_
Level 5
Level 5
Hi,



When I try to view the xml source of my form, I have a runtime error c++ and Designer crashes. It doesn't happen on all my forms. Has my form to many scripts or objects ? Or Is my development environment not appropriate to work correctly ?



I develop with Windows XP 2GO ram, Livecycle ES JBOSS Turnkey installation.



Thanks for any advice.
13 Replies
pguerett
Level 10
Level 10
Does this only happen on that one form or on every form?
_jerome_dinnat_
Level 5
Level 5
I try with a simple form and there was no runtime error. It happens with this form (in different versions) and an other based on it.
pguerett
Level 10
Level 10
So there is something with that form ..can you post it to livecycle8@gmail.com and I will have a look.
_jerome_dinnat_
Level 5
Level 5
Hello,



I think so too. I have send my form to you just now.



Thanks
Not applicable
Hello!



I have the same problem in two different forms. This didn't happen at the beginning, but as more I do "copy and paste" on the fields, the form has become slow on opening and I cannot see the XML source.



Details when I got the error:

AppName: formdesigner.exe

AppVer: 8.2.1.3144 ModName: kernel32.dll

ModVer: 5.1.2600.5512 Offset: 00012aeb



Thanks for help!



Diego
pguerett
Level 10
Level 10
Can you send the forms to livecycle8@gmail.com and I will look into it. Also give me a brief description of the issue in the email.
Not applicable
Paul, I am also having the same problem on a Risk Assessment forms that I have made. The file size was about 798 and when I placed many of the main repeated items on a Mast Page it seemed to stop, then it started again today.



Bill G
pguerett
Level 10
Level 10
Note sure what you are referring to ..can you elaborate?
Not applicable
Hello Paul,



Thank you for your help, but the project that I'm working on I'm unable to send to you the PDF file, for security policies reason.



The form has 11 pages and trying to solve the problem I deleted 10 pages. So now I can see the XML Source but I found a weird thing:

in a Decimal Field, I found up to 65.000 occurrences of
instead of just one. What is it mean?



Is there another way to see the XML source?



Diego
Thomas_McConnac
Level 4
Level 4
Hi Diego,



I noticed this on my form and googled it. Seems to be some sort of bug. I've tested removing all but 1 instance of "
" every time it appears in multiples and my form still works, though I've noticed more of them appearing so I'll be going through when I've finished and removing them again!
Not applicable
Hi Thomas,



Wow! What a mess!



As I said, my form has 11 pages, and I analyzed one by one and at the end the total was about ONE million occurrences of this "
".

1.000.000 for 11 pages form?



That's why my form was too slow when opening in Reader, so I removed all these occurrences and BINGO! Now works good!



Diego
Thomas_McConnac
Level 4
Level 4
A million? Thats way above mine, I was only on about 10,000 and back up to 1,000 of them now judging by my line count.



Tom
Not applicable
Sorry, I posted a new thread, I hadn't seen this one.



I have the same problem. My form crashes, I can't do anything, neither seeing the XML code. I managed to copy a table to another form and the XML code has thousands of repeated lines:











.....



How can I solve this mess with my main form? I can't edit the XML code!