Rows Repeating

Avatar

05-03-2009

I have this form with some tables.. and forms containing the tables, both of which can be duplicated (repeated)..



If I reopen a save form some rows will have already duplicated without any actions..



So for example.. I make a form with a table that originally has 1 row.. and new rows can be added.. in LiveCycle Designer it works prefectly



When I open in Acrobat it begins with 4 rows?.. and if I resave then it doubles to 8..

Replies

Avatar

Avatar
Boost 500
Level 10
pguerett
Level 10

Likes

612 likes

Total Posts

7,689 posts

Correct reply

692 solutions
Top badges earned
Boost 500
Boost 50
Boost 5
Boost 3
Boost 250
View profile

Avatar
Boost 500
Level 10
pguerett
Level 10

Likes

612 likes

Total Posts

7,689 posts

Correct reply

692 solutions
Top badges earned
Boost 500
Boost 50
Boost 5
Boost 3
Boost 250
View profile
pguerett
Level 10

05-03-2009

Then you must have a command that is adding three rows when it initializes .....did you add any code to initialize, formready or docready, validate or caluculation events?

Avatar

Avatar
Boost 500
Level 10
pguerett
Level 10

Likes

612 likes

Total Posts

7,689 posts

Correct reply

692 solutions
Top badges earned
Boost 500
Boost 50
Boost 5
Boost 3
Boost 250
View profile

Avatar
Boost 500
Level 10
pguerett
Level 10

Likes

612 likes

Total Posts

7,689 posts

Correct reply

692 solutions
Top badges earned
Boost 500
Boost 50
Boost 5
Boost 3
Boost 250
View profile
pguerett
Level 10

05-03-2009

Then you must have a command that is adding three rows when it initializes .....did you add any code to initialize, formready or docready, validate or caluculation events?

Avatar

05-03-2009

Nothing in the initialize for the rows.. table.. or form it belongs to.

Avatar

10-03-2009

The thing I dont understand is why it works in Acrobat (no extra rows) and not in Reader (extra rows)?

Avatar

Avatar
Boost 500
Level 10
pguerett
Level 10

Likes

612 likes

Total Posts

7,689 posts

Correct reply

692 solutions
Top badges earned
Boost 500
Boost 50
Boost 5
Boost 3
Boost 250
View profile

Avatar
Boost 500
Level 10
pguerett
Level 10

Likes

612 likes

Total Posts

7,689 posts

Correct reply

692 solutions
Top badges earned
Boost 500
Boost 50
Boost 5
Boost 3
Boost 250
View profile
pguerett
Level 10

10-03-2009

Can you send the form to livecycle8@gmail.com and I will have a look. Make sure to describe the issue in your email and how to reproduce it.

Avatar

11-03-2009

I figured it out.. I was using the same Subform and Table names in 2 sections.. so when I execute addinstance something goofy was going on.. I renamed everything to be unique.. seems to have fixed the problem..