Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Response from webservice : object aggregate

_Frederik-Jan_R
Level 2
Level 2
Dear,<br /><br />I have an Interactive Form with a ton of data on it. I'm using a Web Service to post this data to a system, the return value is always 1 for testing purposes.<br /><br />Using SoapUI I can see and test the service. The return is put like this with constants (so it's always this, never different for testing purposes) :<br /><br /><SOAP:Envelope xmlns:SOAP="http://schemas.xmlsoap.org/soap/envelope/"><br /> <SOAP:Header/><br /> <SOAP:Body><br /> <ns1:AdobePDF xmlns:ns1="http://host.be/pi/PI/Time_Registration"><br /> <RETURN>Test return message</RETURN><br /> <ERROR>1</ERROR><br /> </ns1:AdobePDF><br /> </SOAP:Body><br /></SOAP:Envelope><br /><br />I call the webservice in my form with a button with this code :<br /><br />var response = SOAP.request ({<br />cURL: "http://host:port/XISOAPAdapter/MessageServlet?channel=:BS_TIMEREGISTRATION:CC_SOAP_UpdateTimereg&version=3.0&Sender.Service=BS_TIMEREGISTRATION&Interface=http://host.be/pi/PI/Time_Registration^MI_TimeRegistration",<br />oRequest: myRequest,<br />cAction: "http://host.be/pi/PI/TimeRegistration",<br />oAuthenticate: myAuthentication<br />});<br /><br />I can check the webservice using a monitor and it is posted and sent correctly. There is also a return value in the monitor.<br /><br />The response should be caught in the variable response.<br /><br />xfa.host.messageBox("Response : " + response + "","Information",3);<br /><br />The above returns "Response : Object aggregate".<br /><br />var result = response\"AdobePDF\";<br />xfa.host.messageBox("Result : " + result + "","Information",3);<br /><br />The above returns "Result : undefined".<br /><br />var result = response\"AdobePDF\"\"RETURN\";<br />xfa.host.messageBox("Return : " + result + "","Information",3);<br /><br />The above returns an error : "response.AdobePDF has no properties".<br /><br />Any ideas?<br /><br />Thanks in advance,<br />Frederik-Jan Roose
1 Reply
_Frederik-Jan_R
Level 2
Level 2
The problem apparently was the namespace, removing this and I could use the normal way of retrieving data from XML files.