Highlighted

Problem with Send Email with Attachments (Sample)

Avatar

Guest

16-07-2008

Hi,

We've just tried to send an email after a form validation.

We have used the activity(processes) "Send Email with attachments" proposed in Samples - Foundation -> E-mail - 1.0 .

We fill out "to addresses", "from addresses" and "connection settings".

But no mail are sent.

We are sure that connection settings are good because when an operation is halted we have an email of error (option in server administration).



Exeception raised is :

Caused by: javax.mail.AuthenticationFailedException



We have tried with "Send email" activity (samples foundation components Send email)

In this activity there is no connection settings, we think it use settings in server administration.

But here Exeception raised is :

Caused by: java.lang.Exception: Incorrect SMTP server provided



Have you got an idea? please

Replies

Highlighted

Jasmin_Charbonn

16-07-2008

What SMTP provider are you using?



You have to configure that on the Send Email with attachments operation. This is a different configuration than the email you get when there's an exception.



Jasmin
Highlighted

Avatar

Guest

16-07-2008

Hi,

Thank you for your celerity.

We use an Microsoft exchange firm server.

"This is a different configuration than the email you get when there's an exception" :

What is the difference between exception configuration and email configuration ?
Highlighted

Avatar

Guest

17-07-2008

The email you get when an exception occurs is sent by the LiveCycle ES server.



The email that is sent using the Send Email operation is sent by the Email service.



These are two totally separate email clients.



For information about how to configure services using Workbench, search for "Editing service configurations"



For information about the configuration properties for the Email service, see Workbench Help > Creating Processes > Service Reference > Email > Email Service Configuration



scott
Highlighted

Avatar

Guest

18-07-2008

Hi,

Thank everybody.

In the activity "Send Email with Attachments" ,we have filled out "SMTP host" by IP adress and not the SMTP name.
Highlighted

Avatar

Guest

03-08-2008

I received info from Miad this morning regarding aircond for truck WNE 6309 is not functioning due to compressor problem. We need your kind help to rectify the problem. Instead of that, the rear tire also punctured and has to pump every morning.
Highlighted

BPM_user

09-12-2008

Hi

I am having problem sending email alerts to the users. The email settings is configured in the administration console.When I use the send email with attachmnets option I get the error - 'java.lang.RuntimeException: javax.mail.AuthenticationFailedException'- what does this mean?

I have hardcoded my email address in send options and checked the connection settings option as the email settings was done in administration console. Please help me out with this.



Thanks!
Highlighted

Jasmin_Charbonn

09-12-2008

The send email with attachment service is a seperate service than the email notification from the adminui.



This service doesn't use the settings configured in adminui, but uses it own settings.



You'll to configure them again on the service.



Jasmin
Highlighted

BPM_user

09-12-2008

Thanks for the response.

here is the error which I get when I send email with attachmnets now. I have given the IP address of the SMTP server which we are using.

the error is. I am not sure of what to give in the attachments.I have a form which we use in the application but not sure how to send it as attachment.



java.lang.RuntimeException: Attachments of type:class com.adobe.idp.taskmanager.form.impl.xfa.XFARepositoryFormInstance are not supported