Highlighted

Problem Deploying to WebSphere -Win Server 2003 EE SP2, MS-Sql Server 2005 SP1

Avatar

18-06-2008

hello everyone!



I'm trying to configure LiveCycle ES with WebSphere.

I configured the WebSphere Server and installed the LC ES server too.

But when I run the "Deploy LiveCycle ES EARs" Task using configuration manager it is not installing any more when CPU share becomes 100%.



adobe-livecycle-native-websphere-[os].ear

adobe-livecycle-websphere.ear

adobe-workspace-client.ear



Can somebody help me?



Thanks

Replies

Highlighted

Avatar

Avatar

neptas

Avatar

neptas

neptas

24-06-2008

Hi,



Did you solve this?



Thank you
Highlighted

Avatar

Avatar

JohnFait

Avatar

JohnFait

JohnFait

14-07-2008

Please post the LCM log {found in configurationManager\log}
Highlighted

Avatar

21-07-2008

*** CDV:INFO: * This is a single server configuration.

*** CDV:INFO: *

*** CDV:INFO: *

*** CDV:INFO: * ----------------------------------------------------------------------

*** CDV:INFO: * Deployment

*** CDV:INFO: * ----------------------------------------------------------------------

[2008-07-21 16:14:32,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: *

[2008-07-21 16:14:32,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: * This is a single server configuration.

[2008-07-21 16:14:32,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: *

[2008-07-21 16:14:32,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: *

[2008-07-21 16:14:32,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: * ----------------------------------------------------------------------

[2008-07-21 16:14:32,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: * Deployment

[2008-07-21 16:14:32,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: * ----------------------------------------------------------------------

[2008-07-21 16:16:17,250], FINE , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, Parsing WAS response: ADMA5016I: LiveCycle8 설치가 시작되었습니다.



[2008-07-21 16:16:17,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: ADMA5016I: LiveCycle8 설치가 시작되었습니다.

[2008-07-21 16:16:43,250], FINE , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, Parsing WAS response: ADMA5058I: 전개 대상 버전에 대해 응용프로그램 및 모듈 버전의 유효성을 검증했습니다.

ADMA5018I: EAR(Enterprise Archive) 파일 C:\Documents and Settings\Administrator\Local Settings\Temp\app59278.ear에서 EJBDeploy 명령을 실행 중입니다.

Starting workbench.

framework search path: c:\Program Files\IBM\WebSphere\AppServer\deploytool\itp\plugins



[2008-07-21 16:16:43,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: ADMA5058I: 전개 대상 버전에 대해 응용프로그램 및 모듈 버전의 유효성을 검증했습니다.

[2008-07-21 16:16:43,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: ADMA5018I: EAR(Enterprise Archive) 파일 C:\Documents and Settings\Administrator\Local Settings\Temp\app59278.ear에서 EJBDeploy 명령을 실행 중입니다.

[2008-07-21 16:16:43,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: Starting workbench.

[2008-07-21 16:16:43,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: framework search path: c:\Program Files\IBM\WebSphere\AppServer\deploytool\itp\plugins

[2008-07-21 16:17:19,250], FINE , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, Parsing WAS response: Creating the project.

IOException: null

IOException: null

IOException: null

IOException: null

IOException: null

IOException: null

IOException: null

IOException: null

IOException: null

IOException: null

IOException: null

IOException: null

IOException: null

IOException: null

IOException: null

IOException: null

IOException: null

IOException: null

IOException: null

IOException: null

IOException: null

IOException: null

IOException: null

IOException: null

IOException: null

IOException: null

[2008-07-21 16:17:19,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: Creating the project.

[2008-07-21 16:17:19,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: IOException: null

[2008-07-21 16:17:19,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: IOException: null

[2008-07-21 16:17:19,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: IOException: null

[2008-07-21 16:17:19,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: IOException: null

[2008-07-21 16:17:19,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: IOException: null

[2008-07-21 16:17:19,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: IOException: null

[2008-07-21 16:17:19,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: IOException: null

[2008-07-21 16:17:19,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: IOException: null

[2008-07-21 16:17:19,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: IOException: null

[2008-07-21 16:17:19,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: IOException: null

[2008-07-21 16:17:19,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: IOException: null

[2008-07-21 16:17:19,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: IOException: null

[2008-07-21 16:17:19,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: IOException: null

[2008-07-21 16:17:19,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: IOException: null

[2008-07-21 16:17:19,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: IOException: null

[2008-07-21 16:17:19,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: IOException: null

[2008-07-21 16:17:19,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: IOException: null

[2008-07-21 16:17:19,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: IOException: null

[2008-07-21 16:17:19,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: IOException: null

[2008-07-21 16:17:19,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: IOException: null

[2008-07-21 16:17:19,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: IOException: null

[2008-07-21 16:17:19,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: IOException: null

[2008-07-21 16:17:19,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: IOException: null

[2008-07-21 16:17:19,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: IOException: null

[2008-07-21 16:17:19,250], INFO , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, parseString: IOException: null

[2008-07-21 16:17:20,250], FINE , Thread-9, com.adobe.livecycle.cdv.util.JaclResponseParser, Parsing WAS response:
Highlighted

Avatar

Avatar

JohnFait

Avatar

JohnFait

JohnFait

21-07-2008

Would you be able to attach the full log along with the WAS server log.



It may be best in the meantime to proceed with deploying the 3 ears using the WAS admin console rather then using LCM.
Highlighted

Avatar

21-09-2008

Could you resolve this problem?



I have same problem when I patch the SP2 to LCM on WebSphere.

So if yes, could you tell me how to.



Best Regards.
Highlighted

Avatar

Avatar

Jayan_Kandathil

Avatar

Jayan_Kandathil

Jayan_Kandathil

21-09-2008

I have learned from experience that deploying the EAR files manually is a better option. Start in this order:



- adobe-workspace-client.ear (smallest file, quickest deployment)

- adobe-livecycle-native-websphere-[os].ear

- adobe-livecycle-websphere.ear (largest file, longest deployment because this EAR has a lot of EJBs)
Highlighted

Avatar

09-10-2008

yes, i solved this problem

LC AEDP Suggest for me



---------------------------------------------------------------------

Looking at the SystemOut.log it seems that there is an error in Websphere not being able to deploy the ears on your server. Is your Windows Server 2003 server uses Japanese as base locale? If it is, then please perform the following:



1. Stop and undeploy (or un-install) adobe-livecycle-native-websphere-[OS].ear and adobe-workspace-client.ear ears from Websphere. Since adobe-livecycle-websphere.ear is not started yet, then simply just undeploy it.

2. Login to Websphere admin console

3. Browse to Server > Application Server > server 1

4. Under Server Infrastructure, click Java and Process Management > Process Definition

5. Under Addition Properties, click Java Virtual Machine

6. In the Generic JVM argument box, remove Dfile.encoding=utf8, click Ok and Apply

7. Save the changes to Master Configuration and Restart Websphere



Once all steps outlined above are completed, redeploy the ear files manually to Websphere and attempt to start them. If they were all deployed and started successfully. Add Dfile.encoding=utf8 to the Generic JVM arguments, save the change and restart Websphere.



--------------------------------------------------------------------



useful for U