Highlighted

LiveCycle ES Database Initialization Failing with Bootstrapping error

Avatar

Guest

10-12-2008

I did non-turnkey installation of LCES on windows XP and deployed the adobe-livecycle-jboss.ear on Jboss-4.0.2 app server. Also created databases called adobe and adobe_meta in MySql and grant all permissions to adobe user.

Then configured datasource as per deployment guide with jndi-name as IDP_DS and put the adobe-ds.xml file in server/all/deploy folder.



When I try to initialize the database using Configuration Manager, the following error occurs:

com.adobe.livecycle.bootstrap.BootstrapException: ALC-TTN-103-000: Bootstrapping request failed on server



ALC-TTN-002-001: JDBC datasource lookup failed for resource reference [java:comp/env/jdbc/

IdpDs]. The most likely cause is that a datasource having a JNDI

name of [IDP_DS] does not exist or is misconfigured. Check the application

server's configuration.



In server console it shows javax.naming.NameNotFoundException: XAConnectionFactory exception.



I am getting LiveCycle Administration Login page but could not loging since database entries have not done yet.



If anybody could help me out of this issue that would be really appreciable.

Replies

Highlighted

Avatar

Guest

11-12-2008

The issue with LiveCycle ES Database Initialization has been resolve and I am able to login to the administration console.



It was an issue with Jboss which was giving some parsing exception. When removed the option ( -Djava.endorsed.dirs=%JBOSS_HOME%/server/all/lib/endorsed ) from the run.bat script, the server started smothly enough to complete the deploy process



Thanks to all and I appreciate the support I got from the forum.



Cheers.