Highlighted

Java plugin in the LC ES2 Enablement image

Avatar

Avatar

Giovanni_Sarbia

Avatar

Giovanni_Sarbia

Giovanni_Sarbia

13-01-2010

Hello,

while testing a demo involving a Java applet (since Flex doesn't do signatures with PKCS#11 tokens) I've found out that, for no apparent reason, the Java version integrated with browsers by default in the ES2 Enablement image is 1.5.0_16. This caused the applet to crash in either Firefox or IE, while installing the current 1.6 release everthing works fine. The applet actually works fine on non-64-bit Windows versions, so there's probably some problem with the old 1.5 versions, Windows Server 2008 64-bit and browsers.

I would suggest you to install the current Java SE version for the browsers in the image to avoid similar problems (BTW, by default IE is the 32-bit version even in Windows 2008 64-bit, so if you want to install the Java plugin also for IE 64 you have to install also the 64-bit release of Java).

Best regards,

Giovanni