Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Data look up into SQL


Not applicable
Hi, <br />I have a turnkey set up of Adobe Livecycle 8 running with mySQL and JBOSS on Windows 2003 Server. I also have SQL MSDE installed on the same computer. The goal is to create a SQL data look up from livecycle into SQL. Unfortunately I am running into a couple of issues. <br />In the LC process I have a query single row activity. When I try to enter something in the Datasource Name and try to test my query I get <br />Exception: SQL_LF not bound. Cause: SQL_LF not bound<br /><br />SQL_LF is the data source name I was trying to get to work. How do I get the correct JNDI connection string? I looked online almost the entire day, and I still can't quite get it working. As I understand I need to create a data connection from jboss into SQL and then have livecycle use that data connection. In order to accomplish that I create mssql-ds.xml in C:\Adobe\LiveCycle8.2\jboss\server\all\deploy directory with the following text:<br /><br /><?xml version="1.0" encoding="UTF-8"?><br /><datasources><br /> <local-tx-datasource><br /> <jndi-name>SQL_LF</jndi-name><br /> <connection-url>jdbc:sqlserver://localhost;instancename=lf;databaseName=test</connection-url><br /> <driver-class></driver-class><br /> <user-name>XXXXXX</user-name><br /> <password>XXXXXXX</password><br /> </local-tx-datasource><br /></datasources><br />When I try to make SQL_LF a datasource name it doesn't recognize it. I also tried to enter every imaginable string into that Datasource Name field in LC and it still doesn't work. Is there a paper or a manual on a standard process to create a JNDI link in livecycle to a SQL database?<br /><br />Thanks in advance
1 Reply


Level 10
Have you tried to put java:/SQL_LF or java/SQL_LF.

Also make sure you rebooted you JBoss after creating your *-ds.xml file.

Do you have any error in the log. I've seen instance where the ds file would not deploy properly when created with Notepad.