Basic Chat may not work behind firewa;;

Avatar

Avatar
Level 1
Anthony_T_DeBon
Level 1

Likes

0 likes

Total Posts

1 post

Correct reply

0 solutions
View profile

Avatar
Level 1
Anthony_T_DeBon
Level 1

Likes

0 likes

Total Posts

1 post

Correct reply

0 solutions
View profile
Anthony_T_DeBon
Level 1

26-11-2008

We have a Firewall and my basic Chat app does not work here.

Any ideas?



Also spelling issue in message-I think...

"Got a Failed and I'm the last protocol"



This is the output in the consule in debug mode



Getting FMS at
https://na2.connectnow.acrobat.com/fms?ticket=1jj1qjg3bo2pe,
attempt #1/3

result: <fms>

<origin>fms4.acrobat.com</origin>

<proto_ports>rtmps:443</proto_ports>

<retry_attempts>2</retry_attempts>

</fms>

#FMSConnector# Wed Nov 26 15:16:26 GMT-0500 2008 protocols:
[object ProtocolPortPair]

#FMSConnector# Wed Nov 26 15:16:26 GMT-0500 2008 [attempt 1
of 2] Connecting to 0/0:
rtmps://fms4.acrobat.com/cocomo/na2-sdk-331a24e7-9ffb-4197-bd6e-7e16db480382/test
#startProtosConnect#

#FMSConnector# Wed Nov 26 15:16:27 GMT-0500 2008
tempNetStatusHandler 0/1,NetConnection.Connect.Failed

#FMSConnector# Wed Nov 26 15:16:27 GMT-0500 2008 Got a Failed
and I'm the last protocol, trying again in 2

#FMSConnector# Wed Nov 26 15:16:29 GMT-0500 2008
incOriginsIndex: _originsIndex now:0 (origin:fms4.acrobat.com)

#FMSConnector# Wed Nov 26 15:16:29 GMT-0500 2008 [attempt 2
of 2] Connecting to 0/0:
rtmps://fms4.acrobat.com/cocomo/na2-sdk-331a24e7-9ffb-4197-bd6e-7e16db480382/test
#startProtosConnect#

#FMSConnector# Wed Nov 26 15:16:31 GMT-0500 2008
tempNetStatusHandler 0/1,NetConnection.Connect.Failed

#FMSConnector# Wed Nov 26 15:16:31 GMT-0500 2008 Got a Failed
and I'm the last protocol, trying again in 2

#FMSConnector# Wed Nov 26 15:16:33 GMT-0500 2008
incOriginsIndex: _originsIndex now:0 (origin:fms4.acrobat.com)

#FMSConnector# Wed Nov 26 15:16:33 GMT-0500 2008
startProtosConnect calling onDoneRetryingTimerComplete

Getting FMS at
https://na2.connectnow.acrobat.com/fms?ticket=1jj1qjg3bo2pe&connect-error=true&origin=fms4.acrobat.c...,
attempt #2/3

result: <fms>

<origin>fms4.acrobat.com</origin>

<proto_ports>rtmps:443</proto_ports>

<retry_attempts>2</retry_attempts>

</fms>

#FMSConnector# Wed Nov 26 15:16:33 GMT-0500 2008 protocols:
[object ProtocolPortPair]

#FMSConnector# Wed Nov 26 15:16:33 GMT-0500 2008 [attempt 1
of 2] Connecting to 0/0:
rtmps://fms4.acrobat.com/cocomo/na2-sdk-331a24e7-9ffb-4197-bd6e-7e16db480382/test
#startProtosConnect#

#FMSConnector# Wed Nov 26 15:16:35 GMT-0500 2008
tempNetStatusHandler 0/1,NetConnection.Connect.Failed

#FMSConnector# Wed Nov 26 15:16:35 GMT-0500 2008 Got a Failed
and I'm the last protocol, trying again in 2

#FMSConnector# Wed Nov 26 15:16:37 GMT-0500 2008
incOriginsIndex: _originsIndex now:0 (origin:fms4.acrobat.com)

#FMSConnector# Wed Nov 26 15:16:37 GMT-0500 2008 [attempt 2
of 2] Connecting to 0/0:
rtmps://fms4.acrobat.com/cocomo/na2-sdk-331a24e7-9ffb-4197-bd6e-7e16db480382/test
#startProtosConnect#

#FMSConnector# Wed Nov 26 15:16:38 GMT-0500 2008
tempNetStatusHandler 0/1,NetConnection.Connect.Failed

#FMSConnector# Wed Nov 26 15:16:38 GMT-0500 2008 Got a Failed
and I'm the last protocol, trying again in 2

#FMSConnector# Wed Nov 26 15:16:40 GMT-0500 2008
incOriginsIndex: _originsIndex now:0 (origin:fms4.acrobat.com)

#FMSConnector# Wed Nov 26 15:16:40 GMT-0500 2008
startProtosConnect calling onDoneRetryingTimerComplete

Getting FMS at
https://na2.connectnow.acrobat.com/fms?ticket=1jj1qjg3bo2pe&connect-error=true&origin=fms4.acrobat.c...,
attempt #3/3

result: <fms>

<origin>fms4.acrobat.com</origin>

<proto_ports>rtmps:443</proto_ports>

<retry_attempts>2</retry_attempts>

</fms>

#FMSConnector# Wed Nov 26 15:16:41 GMT-0500 2008 protocols:
[object ProtocolPortPair]

#FMSConnector# Wed Nov 26 15:16:41 GMT-0500 2008 [attempt 1
of 2] Connecting to 0/0:
rtmps://fms4.acrobat.com/cocomo/na2-sdk-331a24e7-9ffb-4197-bd6e-7e16db480382/test
#startProtosConnect#

#FMSConnector# Wed Nov 26 15:16:42 GMT-0500 2008
tempNetStatusHandler 0/1,NetConnection.Connect.Failed

#FMSConnector# Wed Nov 26 15:16:42 GMT-0500 2008 Got a Failed
and I'm the last protocol, trying again in 2

#FMSConnector# Wed Nov 26 15:16:44 GMT-0500 2008
incOriginsIndex: _originsIndex now:0 (origin:fms4.acrobat.com)

#FMSConnector# Wed Nov 26 15:16:44 GMT-0500 2008 [attempt 2
of 2] Connecting to 0/0:
rtmps://fms4.acrobat.com/cocomo/na2-sdk-331a24e7-9ffb-4197-bd6e-7e16db480382/test
#startProtosConnect#

#FMSConnector# Wed Nov 26 15:16:46 GMT-0500 2008
tempNetStatusHandler 0/1,NetConnection.Connect.Failed

#FMSConnector# Wed Nov 26 15:16:46 GMT-0500 2008 Got a Failed
and I'm the last protocol, trying again in 2

#FMSConnector# Wed Nov 26 15:16:48 GMT-0500 2008
incOriginsIndex: _originsIndex now:0 (origin:fms4.acrobat.com)

#FMSConnector# Wed Nov 26 15:16:48 GMT-0500 2008
startProtosConnect calling onDoneRetryingTimerComplete

Replies

Avatar

Avatar
Validate 1
Level 1
Chad_L_
Level 1

Likes

0 likes

Total Posts

8 posts

Correct reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
Chad_L_
Level 1

Likes

0 likes

Total Posts

8 posts

Correct reply

0 solutions
Top badges earned
Validate 1
View profile
Chad_L_
Level 1

02-12-2008


quote:




Originally posted by:
ATD


We have a Firewall and my basic Chat app does not work here.







This is interesting because I'm also behind a fairly tight
firewall and have no trouble getting through to the servers using
the example chat program. I'm no expert, but I think RTMP can
tunnel, and if that is the case it should slip through firewalls
that might be inspecting the packets to see if they are indeed
valid HTTP packets. I'm not sure though if they RTMP tunneling is
turned on by default or if its the regular non-tunneling RTMP they
are using for this.



Chad

Avatar

Avatar
Level 1
east_cocomo
Level 1

Likes

0 likes

Total Posts

3 posts

Correct reply

0 solutions
View profile

Avatar
Level 1
east_cocomo
Level 1

Likes

0 likes

Total Posts

3 posts

Correct reply

0 solutions
View profile
east_cocomo
Level 1

02-12-2008

My chat has no trouble work behind firewall.



Maybe is other reason

Avatar

Avatar
Boost 50
Employee
Raff_
Employee

Likes

80 likes

Total Posts

758 posts

Correct reply

75 solutions
Top badges earned
Boost 50
Boost 5
Boost 3
Boost 25
Boost 10
View profile

Avatar
Boost 50
Employee
Raff_
Employee

Likes

80 likes

Total Posts

758 posts

Correct reply

75 solutions
Top badges earned
Boost 50
Boost 5
Boost 3
Boost 25
Boost 10
View profile
Raff_
Employee

04-12-2008

So, here is the deal: currently Cocomo only supports rtmps
(rtmp over SSL) and not rtmpt (rtmp tunneling over http), but we do
have support for going through a proxy. Only problem: I think I
found a bug because I don't see the messages that say that we are
trying to connect through the proxy.



I'll try a fix in the next few days (and if you can open a
bug it would help us to not forget 🙂 but it would be very helpful
if you could tell us how your firewall / proxy is configured so
that we can do some testing (the current code was inherited from an
older project and the people that wrote it, tested it and had some
clue on how to setup a proxy for testing are long gone 🙂



thanks!



-- Raffaele