Highlighted

ALC-UPG-080-002: Failed to migrate critical data

Avatar

Avatar

Els_Uyttenhove

Avatar

Els_Uyttenhove

Els_Uyttenhove

14-10-2008

Hi,



Environment:

Windows 2003, adobe livecycle ES 8.2, preconfigured jboss 4.2.0, oracle10g database (10.2.0.3)



During the upgrade (ES 7.2.2 to 8.2), the configuration manager failed at the screen "Migrate Data Essential to LiveCycle ES Operation" with the error code:

ALC-UPG-001-503: [Forms] plugin execution failed, error message from plugin is [ALC-UPG-080-002: Failed to migrate critical data.]. See LCM logs for details.



The output of the LCM log:

[2008-10-14 12:50:11,230], INFO, AWT-EventQueue-0, com.adobe.livecycle.upgrade.gui.UpgradePhaseDialog, ALC-UPG-080-024: Migrate critical data for Forms started...

[2008-10-14 12:50:11,250], INFO, AWT-EventQueue-0, com.adobe.livecycle.upgrade.gui.UpgradePhaseDialog, java.lang.RuntimeException

at com.adobe.idp.config.remote.client.AdobeRemotePreferenceFactory.systemRoot(AdobeRemotePreferenceFactory.java:172)

at com.adobe.livecycle.upgrade.forms.FormsUpgradePlugin.migrateCriticalData(FormsUpgradePlugin.java:220)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

at java.lang.reflect.Method.invoke(Method.java:585)

at com.adobe.livecycle.upgrade.control.PhaseRunner.run(PhaseRunner.java:217)

at java.lang.Thread.run(Thread.java:595)



[2008-10-14 12:50:11,260], SEVERE, Thread-18, com.adobe.livecycle.upgrade.control.PhaseRunner, Aborting. Invocation of method [migrateCriticalData] failed for com.adobe.livecycle.upgrade.forms.FormsUpgradePlugin. Caught com.adobe.livecycle.upgrade.UpgradeException, message: ALC-UPG-080-002: Failed to migrate critical data.

com.adobe.livecycle.upgrade.UpgradeException: ALC-UPG-080-002: Failed to migrate critical data.

at com.adobe.livecycle.upgrade.forms.FormsUpgradePlugin.migrateCriticalData(FormsUpgradePlugin.java:295)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

at java.lang.reflect.Method.invoke(Method.java:585)

at com.adobe.livecycle.upgrade.control.PhaseRunner.run(PhaseRunner.java:217)

at java.lang.Thread.run(Thread.java:595)

Caused by: java.lang.RuntimeException

at com.adobe.idp.config.remote.client.AdobeRemotePreferenceFactory.systemRoot(AdobeRemotePreferenceFactory.java:172)

at com.adobe.livecycle.upgrade.forms.FormsUpgradePlugin.migrateCriticalData(FormsUpgradePlugin.java:220)

... 6 more



I looked up ALC-UPG-080-002 in the LiceCycle ES Error Code Reference, but information has to be added.



The output of the jboss server.log:



2008-10-14 12:50:10,029 ERROR [STDERR] 14-okt-2008 12:50:09 com.adobe.livecycle.encryption.pdfmmcompatibility.BootstrapImpl setBootstrapContext

INFO: Set bootstrap context: com.adobe.livecycle.encryption.pdfmmcompatibility

2008-10-14 12:50:10,099 ERROR [STDERR] 14-okt-2008 12:50:10 com.adobe.livecycle.encryption.pdfmmcompatibility.BootstrapImpl onInstall

INFO: Called onInstall: com.adobe.livecycle.encryption.pdfmmcompatibility

2008-10-14 12:50:10,710 ERROR [STDERR] 14-okt-2008 12:50:10 com.adobe.livecycle.encryption.pdfmmcompatibility.LifeCycleImpl onStart

INFO: Called onStart: com.adobe.livecycle.encryption.pdfmmcompatibility:com.adobe.livecycle.encryption.pdfmmcompatibility.LifeCycleImpl@d88a47



At the deploy of the LiveCycle ES EAR files, I got the same error as Sergey Yazlavetski (http://www.adobeforums.com/webx/.59b62a2f/1),

but I could continue without errors until the migrate critical data for forms started.



Any suggestions will be appreciated,

kind regards,

Els

Replies

Highlighted

Avatar

Avatar

yodadobe

Avatar

yodadobe

yodadobe

24-10-2008

I'm not sure if our errors were exactly the same, but migration failed for us as well. I only cared about the processes so I exported them all on the old version. We started as a fresh install then imported the process archives.
Highlighted

Avatar

20-01-2009

Els Uyttenhove..., I'm in the same boat as you. Got the following error while installing ES on Linux.

ALC-UPG-080-002: Failed to migrate critical data



Can you please let me know how got over it?



Thank You !!
Highlighted

Avatar

Avatar

Els_Uyttenhove

Avatar

Els_Uyttenhove

Els_Uyttenhove

26-01-2009

I solved it by deinstalling everything from the old version (7.2.2) and I did a new install for the Livecycle ES 8.2 software without any problem. So upgrading from 7.2.2 to 8.2 didn't work for me, but a new install has no problems.

For me it was possible to do so, because we only use forms and reader extensions, and I lost no data, but I think this isn't a solution for everyone......



Good luck!
Highlighted

Avatar

28-01-2009

Els.., Thanks for getting back to me. My problem is solved. Here is the list of things I did to fix it:



1) Delete main Livecycle directory on Linux

2) Manually uninstall all the ear files from Websphere admin console

3) Perform a fresh install

4) Carefully use the port numbers. (SOAP port is pulled from Deployment Manager and Appserver's ORB port is used for JNDI).



Thanks !!