Highlighted

Adobe wsdl Soap call only accepts one input - PHP

Avatar

15-04-2009

Hello and thanks for reading,

I am stuck as to why my ES workflow is only accepting one input from my PHP soap call.

My workflow expects two inputs, a record ID and an email address.

I setup an array, called $params, to store these values (ex. $params['recordid'] = 12345 );

When I step through the workflow to debug, I see the record ID set, but the email address input is still empty.

Would anyone have thoughts as to why this would occur? I have my PHP code pasted below for reference.

Thanks!

----

    // Addresses the time to wait for a response
    ini_set('default_socket_timeout', 180);

    // Connect to the WSDL connection above
    $client = new SoapClient( $URL, array("connection_timeout"=>20) );
       
    // Try to initiate the workflow
    try {
        $returnval = $client->invoke_Async($params);
    }  
    catch (SoapFault $exception) {
        $success = 0;
    }

Replies

Highlighted

Avatar

Avatar

workflowuser

Employee

Avatar

workflowuser

Employee

workflowuser
Employee

15-04-2009

hmm, can't think of an reason. But make sure the parameter names in the param hashmap match those of the input parameters defined in the livecycle process

thanks

girish

Highlighted

Avatar

16-04-2009

Thanks for the help!

Here is part of the structure for the wsdl:

<element name="invoke_Async">

     <complexType>

          <sequence>
               <element maxOccurs="1" minOccurs="0" name="acpid" type="xsd:string"/>
               <element maxOccurs="1" minOccurs="0" name="personemail" type="xsd:string"/>
          </sequence>
     </complexType>
</element>

In my PHP code, I am performing the following:

$params["acpid"] = $acpid;
$params["personemail"] = $cemailaddy;

That should be correct right?