Configuring runtime in I/O

Avatar

Avatar

norbertb5623275

Avatar

norbertb5623275

norbertb5623275

18-02-2020

Hi Adobe,

We have got access to I/O runtime beta and received the namespaces for our runtime instances.
By following the documentation we configured the aio CLI and were able to upload and invoke a simple action.
However I believe we are missing one step in the configuration and we never got runtime connected to our I/O console integration.

When we are trying to retrieve the integrations from our I/O sandbox instance via the aio console:list-integrations command we get the following error:
» Error: The value "null" is invalid for option "passphrase"

We could go around this by generating an access token first with the aio jwt-auth:access-token command.

After that we were able to list out the integrations but when we try to run aio console select-integration ORGID_INTID we got the following error:

» Error: Cannot retrieve integration: https://api.adobe.io/runtime/admin/namespaces/ORG_ID/INT_ID (404 Not Found)

Of course we replaced the ORGID_INTID with the actual values from the namespace.

 

This error indicates to me that our I/O console integration is not configured with Runtime. In the documentation there is a step what states:

io_runtime.png
We don't have a possibility to enable Runtime within I/O console. Shouldn't it be Adobe who enables Runtime in our Sandbox instance first ?

Thank you in advance,

Regards,
Norbert

View Entire Topic

Avatar

Avatar

Mihai_Corlan

Employee

Avatar

Mihai_Corlan

Employee

Mihai_Corlan
Employee

13-04-2020

Hello there,

 

Your error is expected as you've got access to I/O Runtime through custom namespaces. This doesn't give you access to I/O Runtime through the Developer Console.

 

We will be revisiting the way we onboarded customers and re-onboard them through the Developer Console. Expect this to be done in May, 2020.