Expand my Community achievements bar.

Dive into Adobe Summit 2024! Explore curated list of AEM sessions & labs, register, connect with experts, ask questions, engage, and share insights. Don't miss the excitement.

Workflow gives "Process Resource" is null error

Avatar

Level 2

Hi, I have created a workflow model with a "Deactivate Page" step only and while running this i am getting "Process Resource null" error.
I have also tried another step "Create page Version" and still getting the same error response.

I have checked "com.day.cq.wcm.workflow" bundle and "create version" component both are active and my workflow model is in sync.


Any suggestion how to solve it?

Work Flow Error:

Hemendra_0-1703427977706.png


Work Flow Model:

Hemendra_1-1703428012200.png

Hemendra_2-1703428029341.png

 

6 Replies

Avatar

Level 4

Hi @Hemendra , Have you checked error logs for the same?

Avatar

Level 2

Hi @Shivam153 
Please find the error logs.

===========================
28.12.2023 12:12:35.765 *ERROR* [JobHandler: /var/workflow/instances/server0/2023-12-28/aem-tutorial-workflow_1:/content/aemtutorial/language-master/en/home] com.adobe.granite.workflow.core.job.JobHandler Error executing workflow step
com.adobe.granite.workflow.WorkflowException: Process resource is null
at com.adobe.granite.workflow.core.job.HandlerBase.executeProcess(HandlerBase.java:134) [com.adobe.granite.workflow.core:2.0.240.CQ674-B0017]
at com.adobe.granite.workflow.core.job.JobHandler.process(JobHandler.java:271) [com.adobe.granite.workflow.core:2.0.240.CQ674-B0017]
at org.apache.sling.event.impl.jobs.JobConsumerManager$JobConsumerWrapper.process(JobConsumerManager.java:502) [org.apache.sling.event:4.2.24]
at org.apache.sling.event.impl.jobs.queues.JobQueueImpl.startJob(JobQueueImpl.java:351) [org.apache.sling.event:4.2.24]
at org.apache.sling.event.impl.jobs.queues.JobQueueImpl.access$100(JobQueueImpl.java:60) [org.apache.sling.event:4.2.24]
at org.apache.sling.event.impl.jobs.queues.JobQueueImpl$1.run(JobQueueImpl.java:287) [org.apache.sling.event:4.2.24]
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
at java.base/java.lang.Thread.run(Thread.java:834)
28.12.2023 12:12:41.394 *INFO* [oak-repository-executor-1] com.adobe.granite.repository Service [8598, [org.apache.jackrabbit.oak.api.jmx.SessionMBean]] ServiceEvent REGISTERED

======End============

Avatar

Community Advisor

@Hemendra 

  •  
  • What is the payload that you are using for the Workflow?
  • How are you initiating these workflows?

Aanchal Sikka

Avatar

Level 2

Hi @aanchal-sikka 
Please find my inline reply-

  • What is the payload that you are using for the Workflow?
    I am using my demo site page, see below-
    Hemendra_0-1703746043572.png

     

  • How are you initiating these workflows?
    I have tried both ways by creating a launcher and by executing it Manually and getting the same error.
    Hemendra_1-1703746149034.png

     

Avatar

Administrator

@Hemendra Did you find the suggestions from users helpful? Please let us know if more information is required. Otherwise, please mark the answer as correct for posterity. If you have found out solution yourself, please share it with the community.



Kautuk Sahni

Avatar

Level 2

@kautuk_sahni  The issue persists with my local environment, and I have been unable to find a solution despite trying multiple approaches. Only the Default workflow model is functional, while any custom workflow models fail to work and result in this same error.

To temporarily address this problem, I have set up a new local instance where this issue does not occur. It appears that there may be an issue related to the initial setup, but I am still uncertain about the specific cause of the problem. I will look more into this and will let the community know if i am able to find any concrete result.

Thanks
Hemendra