Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

WKND tutorial maven archetype 22 issue

p1hampi
Level 2
Level 2

Hi Team, 

Environment : Windows 10 64 bit , Java : OpenJDK12,  Maven 3.6.3 , AEM version 6.5

To get AEM refresher,I am trying WKND tutorial but it giving various plugins error like"Failed to execute goal org.apache.maven.plugins:maven-enforcer-plugin:1.4.1:enforce (enforce-maven) on project aem-guides-wknd: Execution enforce-maven of goal org.apache.maven.plugins:maven-enforcer-plugin:1.4.1:enforce failed: An API incompatibility was encountered while executing org.apache.maven.plugins:maven-enforcer-plugin:1.4.1:enforce: java.lang.ExceptionInInitializerError: null " , 

For solution searched on our League Community, changed enforcer plugin version from 1.4.1 to 3.0.0-M2 but still various problems exists like "filevault-package-maven-plugin" also changed from 1.0.3 to 1.1.2 in main pom.xml 

Can you please provide help. 

Thanks in advance. 

aem6.5 environment maven
1 Accepted Solution
Veena_Vikram
Correct answer by
Community Advisor
Community Advisor

Not sure if this is an issue with JDK12 ? I tried this with JDK 11 and it works fine for me

 

Thanks

Veena

View solution in original post

3 Replies
Veena_Vikram
Correct answer by
Community Advisor
Community Advisor

Not sure if this is an issue with JDK12 ? I tried this with JDK 11 and it works fine for me

 

Thanks

Veena

View solution in original post

BrianKasingli
Community Advisor
Community Advisor

@p1hampi, what is the version of your maven using? Please assign your maven plugin to use JDK 11, this works for me as expected. 

mvn -v
Apache Maven 3.6.0
Java version: 11.0.8, vendor: Oracle Corporation, runtime: /Library/Java/JavaVirtualMachines/jdk-11.0.8.jdk/Contents/Home
...

 

p1hampi
Level 2
Level 2
Hi @BrianKasingli , issue was with maven pointing to OpenJDK12 , I tried with JDK 11.0.8 it worked. Thanks