Expand my Community achievements bar.

Enhance your AEM Assets & Boost Your Development: [AEM Gems | June 19, 2024] Improving the Developer Experience with New APIs and Events
SOLVED

WKND Sites Project getting connection refused for ui.apps

Avatar

Level 1

I am doing the tutorial link . So after cloning and checking all other stuffs I run 

mvn clean install -PautoInstallPackagePublish

but I get 

 

[ERROR] Failed to execute goal com.day.jcr.vault:content-package-maven-plugin:1.0.2:install (default-cli) on project aem-guides-wknd.ui.apps: Connection refused (Connection refused) -> [Help 1]
org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal com.day.jcr.vault:content-package-maven-plugin:1.0.2:install (default-cli) on project aem-guides-wknd.ui.apps: Connection refused (Connection refused)
    at org.apache.maven.lifecycle.internal.MojoExecutor.execute (MojoExecutor.java:215)
    at org.apache.maven.lifecycle.internal.MojoExecutor.execute (MojoExecutor.java:156)
    at org.apache.maven.lifecycle.internal.MojoExecutor.execute (MojoExecutor.java:148)
    at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject (LifecycleModuleBuilder.java:117)
    at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject (LifecycleModuleBuilder.java:81)
    at org.apache.maven.lifecycle.internal.builder.singlethreaded.SingleThreadedBuilder.build (SingleThreadedBuilder.java:56)
    at org.apache.maven.lifecycle.internal.LifecycleStarter.execute (LifecycleStarter.java:128)
    at org.apache.maven.DefaultMaven.doExecute (DefaultMaven.java:305)
    at org.apache.maven.DefaultMaven.doExecute (DefaultMaven.java:192)
    at org.apache.maven.DefaultMaven.execute (DefaultMaven.java:105)
    at org.apache.maven.cli.MavenCli.execute (MavenCli.java:956)
    at org.apache.maven.cli.MavenCli.doMain (MavenCli.java:288)
    at org.apache.maven.cli.MavenCli.main (MavenCli.java:192)
    at jdk.internal.reflect.NativeMethodAccessorImpl.invoke0 (Native Method)
    at jdk.internal.reflect.NativeMethodAccessorImpl.invoke (NativeMethodAccessorImpl.java:62)
    at jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke (DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke (Method.java:566)
    at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced (Launcher.java:289)
    at org.codehaus.plexus.classworlds.launcher.Launcher.launch (Launcher.java:229)
    at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode (Launcher.java:415)
    at org.codehaus.plexus.classworlds.launcher.Launcher.main (Launcher.java:356)
Caused by: org.apache.maven.plugin.MojoExecutionException: Connection refused (Connection refused)


 

Maven and Java versions:

 

hQdOc

 

EDIT: pom.xml 

 

<pre>
<properties>
<aem.host>localhost</aem.host>
<aem.port>4502</aem.port>
<aem.publish.host>localhost</aem.publish.host>
<aem.publish.port>4503</aem.publish.port>
<sling.user>admin</sling.user>
<sling.password>admin</sling.password>
<vault.user>admin</vault.user>
<vault.password>admin</vault.password>
<core.wcm.components.version>2.8.0</core.wcm.components.version>
<bnd.version>4.2.0</bnd.version>
<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
<project.reporting.outputEncoding>UTF-8</project.reporting.outputEncoding>
</properties>
</pre>

 

 

 

 

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

Hi @martinlloyd 

 

If you look at line number 40 in parent pom.xml file

        <aem.publish.host>localhost</aem.publish.host>
        <aem.publish.port>4503</aem.publish.port>
        <sling.user>admin</sling.user>
        <sling.password>admin</sling.password>

There are connection details to your publish server. Make sure to change them accordingly and also ensure your publish server is up and running.

 

Thanks! 

View solution in original post

7 Replies

Avatar

Level 3

Did you enter the correct server details in the main pom.xml of your project. if not, please enter the correct server details , username and password

 

https://github.com/adobe/aem-project-archetype/blob/c66080e74d06cdbfa75151fe0005df5e0e234155/src/mai...

Avatar

Level 1
I didnt change anything on that file and I check they have same settings.

Avatar

Employee
You would need to change the values there. The values are populated with the deafult ones. If you are still facing issues, pelase raise a support ticket and someone would help you further

Avatar

Employee

Did you enter the correct server details in the main pom.xml of your project. if not, please enter the correct server details , username and password

 

https://github.com/adobe/aem-project-archetype/blob/c66080e74d06cdbfa75151fe0005df5e0e234155/src/mai...

Avatar

Correct answer by
Community Advisor

Hi @martinlloyd 

 

If you look at line number 40 in parent pom.xml file

        <aem.publish.host>localhost</aem.publish.host>
        <aem.publish.port>4503</aem.publish.port>
        <sling.user>admin</sling.user>
        <sling.password>admin</sling.password>

There are connection details to your publish server. Make sure to change them accordingly and also ensure your publish server is up and running.

 

Thanks! 

Avatar

Community Advisor

Hi @martinlloyd 

  • Make sure your target AEM instance is started and running normally(all bundles should be active) before you deploy your code.
  • If you have changed the admin username and password of your AEM instance, you might need to update it in your pom.xml.

If you want to deploy your code to author instance running on the port 4502 then use 

mvn clean install -PautoInstallPackage

If you want to deploy your code to publish instance running on the port 4503 then use  

mvn clean install -PautoInstallPackagePublish

If you want to deploy your code to any other instance of AEM running of any port <port> the use

mvn clean install -PautoInstallPackage -Daem.port=<port>

 

Regards,

Arpit

 

Avatar

Community Advisor

Are you trying to install to publish ? Is your server running on 4503 ?