Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

While depolying the ui.content package its not updating the path or the modifications done by me

Avatar

Level 3

While depolying the "ui.content" package its not updating the path or the modifications done by me

 

ex: content/myproject/home.html the jcr:content still showing the existing one let me know about this.

 

I went to the filter.xml file changes also but its not working

 

1 Accepted Solution

Avatar

Correct answer by
Employee Advisor

Hi,

 

I assume that you can reproduce this on your local environment; in that case please install that package via the package manager and check its log for the page you are interested. It should indicate the action (added/updated/none/...). Then double check the filter section (either in the filter.xml or via the package manager UI).

When I had this problem, it was typically a typo in the filter.xml (incorrect path or something like that).

View solution in original post

7 Replies

Avatar

Correct answer by
Employee Advisor

Hi,

 

I assume that you can reproduce this on your local environment; in that case please install that package via the package manager and check its log for the page you are interested. It should indicate the action (added/updated/none/...). Then double check the filter section (either in the filter.xml or via the package manager UI).

When I had this problem, it was typically a typo in the filter.xml (incorrect path or something like that).

Avatar

Level 4

I have seen one more problem with the version in the package manager where it says "A different version seems to be installed". Uninstalling the package and then deploy the code bring my latest changes to AEM. Screen Shot 2021-07-21 at 9.37.19 AM.png

Avatar

Community Advisor

Hi,

Check the filter.xml and its modes, more info

https://jackrabbit.apache.org/filevault/filter.html

if you are using merge then it will not gonna update the existing content.

 

Avatar

Level 3
Hi Arun_Patidar , im using <filter root="page path" mode="update"> still i cant see updated modifications there

Avatar

Community Advisor
can extract the package and check what is the filter looks like and try to do test install by manual uploading.

Avatar

Level 3

Hi Arun_Patidar, Here problem is while deploying using jenkins only not with manually by manually i can do but its has come by through build only that's what im thinking below is the code in filter.

 

 

<workspaceFilter version="1.0">

<filter root="/content/we-retail/en" mode="update"/>
</workspaceFilter>