Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Use Apache OpenCMIS in CQ5.6

Avatar

Level 4

Hello,

I want to use the Apache Chemistry OpenCMIS library in CQ5 for connecting to EMC Documentum server but whenever I try to install my bundle, that is using it, I get this message

23.05.2014 09:58:51.453 *INFO* [OsgiInstallerImpl] org.apache.sling.installer.core.impl.tasks.BundleStartTask Could not start bundle cz.devsoft.hartmann.hartmann-default-bundle [341]. Reason: org.osgi.framework.BundleException: Unresolved constraint in bundle cz.devsoft.hartmann.hartmann-default-bundle [341]: Unable to resolve 341.1684: missing requirement [341.1684] osgi.wiring.package; (&(osgi.wiring.package=org.apache.chemistry.opencmis.client.api)(version>=0.11.0)(!(version>=1.0.0))) [caused by: Unable to resolve 351.0: missing requirement [351.0] osgi.wiring.package; (osgi.wiring.package=javax.jws)]. Will retry. 23.05.2014 09:58:51.454 *INFO* [OsgiInstallerImpl] org.apache.sling.installer.core.impl.tasks.RestartActiveBundlesTask Unable to start bundle cz.devsoft.hartmann.hartmann-default-bundle [341] : Unresolved constraint in bundle cz.devsoft.hartmann.hartmann-default-bundle [341]: Unable to resolve 341.1684: missing requirement [341.1684] osgi.wiring.package; (&(osgi.wiring.package=org.apache.chemistry.opencmis.client.api)(version>=0.11.0)(!(version>=1.0.0))) [caused by: Unable to resolve 351.0: missing requirement [351.0] osgi.wiring.package; (osgi.wiring.package=javax.jws)] 23.05.2014 09:58:51.466 *INFO* [FelixDispatchQueue] org.apache.felix.framework FrameworkEvent PACKAGES REFRESHED 23.05.2014 09:58:51.466 *INFO* [FelixDispatchQueue] org.apache.felix.framework FrameworkEvent PACKAGES REFRESHED 23.05.2014 09:58:51.537 *INFO* [OsgiInstallerImpl] org.apache.sling.installer.core.impl.tasks.BundleStartTask Could not start bundle cz.devsoft.hartmann.hartmann-default-bundle [341]. Reason: org.osgi.framework.BundleException: Unresolved constraint in bundle cz.devsoft.hartmann.hartmann-default-bundle [341]: Unable to resolve 341.1684: missing requirement [341.1684] osgi.wiring.package; (&(osgi.wiring.package=org.apache.chemistry.opencmis.client.api)(version>=0.11.0)(!(version>=1.0.0))) [caused by: Unable to resolve 351.0: missing requirement [351.0] osgi.wiring.package; (osgi.wiring.package=javax.jws)]. Will retry. 23.05.2014 09:58:51.537 *INFO* [OsgiInstallerImpl] org.apache.sling.installer.core.impl.tasks.RestartActiveBundlesTask Unable to start bundle cz.devsoft.hartmann.hartmann-default-bundle [341] : Unresolved constraint in bundle cz.devsoft.hartmann.hartmann-default-bundle [341]: Unable to resolve 341.1684: missing requirement [341.1684] osgi.wiring.package; (&(osgi.wiring.package=org.apache.chemistry.opencmis.client.api)(version>=0.11.0)(!(version>=1.0.0))) [caused by: Unable to resolve 351.0: missing requirement [351.0] osgi.wiring.package; (osgi.wiring.package=javax.jws)]

Here is what I have in my pom.xml

<dependency> <groupId>org.apache.chemistry.opencmis</groupId> <artifactId>chemistry-opencmis-client-impl</artifactId> <version>0.11.0</version> </dependency>

I'm using Eclipse and maven for creating, compiling and installing my bundle. My java version is
 

java version "1.7.0_55" OpenJDK Runtime Environment (rhel-2.4.7.1.el6_5-x86_64 u55-b13) OpenJDK 64-Bit Server VM (build 24.51-b03, mixed mode)

Thanks for any help

1 Accepted Solution

Avatar

Correct answer by
Level 6

Just now I tried to add cmis dependency in my test project and created a bundle and it was active. pfa pom file. can u pls post your code here?

Java version -

java version "1.7.0_55"
Java(TM) SE Runtime Environment (build 1.7.0_55-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.55-b03, mixed mode)

View solution in original post

0 Replies

Avatar

Level 6

As per my knowledge, CRX does not support CMIS although it mentioned here  which creates confusion. Not sure why this link is still active. 

Avatar

Level 4

I also tried to install the OpenCMIS OSGI client via the OSGi console but I got this error

26.05.2014 08:01:26.558 *ERROR* [192.168.56.1 [1401084086454] POST /system/console/bundles/358 HTTP/1.1] cqse-httpservice %bundles.pluginTitle: Cannot start (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.chemistry.opencmis.chemistry-opencmis-osgi-client [358]: Unable to resolve 358.0: missing requirement [358.0] osgi.wiring.package; (osgi.wiring.package=javax.jws)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.chemistry.opencmis.chemistry-opencmis-osgi-client [358]: Unable to resolve 358.0: missing requirement [358.0] osgi.wiring.package; (osgi.wiring.package=javax.jws) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3896) at org.apache.felix.framework.Felix.startBundle(Felix.java:1938) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:947) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:934) at org.apache.felix.webconsole.internal.core.BundlesServlet.doPost(BundlesServlet.java:339) at javax.servlet.http.HttpServlet.service(HttpServlet.java:727) at javax.servlet.http.HttpServlet.service(HttpServlet.java:820) at org.apache.felix.webconsole.internal.servlet.OsgiManager.service(OsgiManager.java:493) at org.apache.felix.webconsole.internal.servlet.OsgiManager.service(OsgiManager.java:418) at org.apache.felix.http.base.internal.handler.ServletHandler.doHandle(ServletHandler.java:96) at org.apache.felix.http.base.internal.handler.ServletHandler.handle(ServletHandler.java:79) at org.apache.felix.http.base.internal.dispatch.ServletPipeline.handle(ServletPipeline.java:42) at org.apache.felix.http.base.internal.dispatch.InvocationFilterChain.doFilter(InvocationFilterChain.java:49) at org.apache.felix.http.base.internal.dispatch.HttpFilterChain.doFilter(HttpFilterChain.java:33) at org.apache.sling.i18n.impl.I18NFilter.doFilter(I18NFilter.java:127) at org.apache.felix.http.base.internal.handler.FilterHandler.doHandle(FilterHandler.java:88) at org.apache.felix.http.base.internal.handler.FilterHandler.handle(FilterHandler.java:76) at org.apache.felix.http.base.internal.dispatch.InvocationFilterChain.doFilter(InvocationFilterChain.java:47) at org.apache.felix.http.base.internal.dispatch.HttpFilterChain.doFilter(HttpFilterChain.java:33) at org.apache.felix.http.sslfilter.internal.SslFilter.doFilter(SslFilter.java:55) at org.apache.felix.http.base.internal.handler.FilterHandler.doHandle(FilterHandler.java:88) at org.apache.felix.http.base.internal.handler.FilterHandler.handle(FilterHandler.java:76) at org.apache.felix.http.base.internal.dispatch.InvocationFilterChain.doFilter(InvocationFilterChain.java:47) at org.apache.felix.http.base.internal.dispatch.HttpFilterChain.doFilter(HttpFilterChain.java:33) at org.apache.sling.security.impl.ReferrerFilter.doFilter(ReferrerFilter.java:259) at org.apache.felix.http.base.internal.handler.FilterHandler.doHandle(FilterHandler.java:88) at org.apache.felix.http.base.internal.handler.FilterHandler.handle(FilterHandler.java:76) at org.apache.felix.http.base.internal.dispatch.InvocationFilterChain.doFilter(InvocationFilterChain.java:47) at org.apache.felix.http.base.internal.dispatch.HttpFilterChain.doFilter(HttpFilterChain.java:33) at com.adobe.granite.license.impl.LicenseCheckFilter.doFilter(LicenseCheckFilter.java:179) at org.apache.felix.http.base.internal.handler.FilterHandler.doHandle(FilterHandler.java:88) at org.apache.felix.http.base.internal.handler.FilterHandler.handle(FilterHandler.java:76) at org.apache.felix.http.base.internal.dispatch.InvocationFilterChain.doFilter(InvocationFilterChain.java:47) at org.apache.felix.http.base.internal.dispatch.HttpFilterChain.doFilter(HttpFilterChain.java:33) at org.apache.sling.engine.impl.log.RequestLoggerFilter.doFilter(RequestLoggerFilter.java:75) at org.apache.felix.http.base.internal.handler.FilterHandler.doHandle(FilterHandler.java:88) at org.apache.felix.http.base.internal.handler.FilterHandler.handle(FilterHandler.java:76) at org.apache.felix.http.base.internal.dispatch.InvocationFilterChain.doFilter(InvocationFilterChain.java:47) at org.apache.felix.http.base.internal.dispatch.HttpFilterChain.doFilter(HttpFilterChain.java:33) at org.apache.felix.http.base.internal.dispatch.FilterPipeline.dispatch(FilterPipeline.java:48) at org.apache.felix.http.base.internal.dispatch.Dispatcher.dispatch(Dispatcher.java:39) at org.apache.felix.http.base.internal.DispatcherServlet.service(DispatcherServlet.java:67) at javax.servlet.http.HttpServlet.service(HttpServlet.java:820) at com.day.j2ee.servletengine.ServletRuntimeEnvironment.service(ServletRuntimeEnvironment.java:250) at com.day.j2ee.servletengine.RequestDispatcherImpl.doFilter(RequestDispatcherImpl.java:321) at com.day.j2ee.servletengine.RequestDispatcherImpl.service(RequestDispatcherImpl.java:340) at com.day.j2ee.servletengine.RequestDispatcherImpl.service(RequestDispatcherImpl.java:383) at com.day.j2ee.servletengine.ServletHandlerImpl.process(ServletHandlerImpl.java:360) at com.day.j2ee.servletengine.HttpListener$Worker.run(HttpListener.java:644) at java.lang.Thread.run(Thread.java:744)

Avatar

Level 4

Hi, thanks for reply. I don't want to use the CMIS for connecting TO CQ5 but to connect to EMC Documentum FROM CQ5.

Avatar

Level 6

may be you are using some other jar files in your custom code which are used by cmis jar and due to unavailability of those jars, you are getting that error. I tried to install cmis client jar directly that u mentined above in both 5.4 n 5.6.1 and it was fine. 

Avatar

Level 6

have you tried to use to Documentum connector that CQ provides

Avatar

Level 4

Sam205505050 wrote...

have you tried to use to Documentum connector that CQ provides

 

I can't use it. I have my own reasons for using the Apache Chemistry OpenCMIS library.

Avatar

Correct answer by
Level 6

Just now I tried to add cmis dependency in my test project and created a bundle and it was active. pfa pom file. can u pls post your code here?

Java version -

java version "1.7.0_55"
Java(TM) SE Runtime Environment (build 1.7.0_55-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.55-b03, mixed mode)

Avatar

Level 4

Sam205505050 wrote...

Just now I tried to add cmis dependency in my test project and created a bundle and it was active. pfa pom file. can u pls post your code here?

Java version -

java version "1.7.0_55"
Java(TM) SE Runtime Environment (build 1.7.0_55-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.55-b03, mixed mode)

 

What code you want to see? The one from the pom.xml or something else?