Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Unable to Open AEM Forms 6.5.12.0 WorkBench

Avatar

Level 2

Hi All,
I have installed AEM Forms 6.5.12.0 WorkBench on my 64 bit windows machine. It installs Workbench and Designer(clubbed with Designer) both successfully but doesn't let me open workbench while the Designer opens successfully.

Following is the AEM Forms 6.5.12.0 WorkBench I have installed :

Workbench6.5.jpg

 

The Error I'm getting while opening is :

Error_while_opening.jpg

 

The content of this log file is :

 

SESSION 2022-08-24 18:27:54.416 ----

eclipse.buildId=unknown

java.version=1.8.0_151

java.vendor=Oracle Corporation

BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US

Framework arguments: #Product Runtime Configuration File

Command-line arguments: -os win32 -ws win32 -arch x86 #Product Runtime Configuration File

! ENTRY org.eclipse.equinox.ds 4 0 2022-08-24 18:27:55.057

!MESSAGE

!STACK 0

org.osgi.framework.BundleException: The bundle "org.eclipse.equinox.ds_1.2.0.v20100507 [4]" could not be resolved. Reason: Missing Constraint: Import-Package: org.eclipse.equinox. internal.util.event; version="1.0.0"

at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1317)

at org.eclipse.osgi. framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1301)

at org.eclipse.osgi.framework.internal.core.BundleHost.startworker(BundleHost.java:319)

at org.eclipse.osgi. framework.internal.core.AbstractBundle.resume (AbstractBundle.java:374)

at org.eclipse.osgi.framework.internal.core. Framework.resumeBundle(Framework.java:1067)

at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles (StartLevelManager.java:561)

at org.eclipse.osgi. framework.internal.core.StartLevelManager.resume Bundles (StartLevelManager.java:546)

at org.eclipse.osgi. framework.internal.core.StartLevelManager.incFWSL (StartLevelManager.java:459)

at org.eclipse.osgi.framework. internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)

at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:440)

at org.eclipse.osgi.framework.eventmgr. EventManager.dispatchEvent(EventManager.java:227)

at org.eclipse.osgi.framework.eventmgr. EventManager $EventThread.run(EventManager.java: 337)

 

! ENTRY org.eclipse.update.configurator 4 0 2022-08-24 18:27:55.119

!MESSAGE Could not load from shared install

! STACK 0

java.lang. Exception: Failed to parse shared configuration: file:/C:/Program Files (x86)/Adobe Experience Manager forms Workbench/workbench/configuration/org.eclipse.update/platform.xml

at org.eclipse.update.internal.configurator.ConfigurationParser.processConfig(ConfigurationParser.java:314)

at org.eclipse.update.internal.configurator.ConfigurationParser.startElement(ConfigurationParser.java:112)

at com.sun.org.apache.xerces.internal.parsers. Abstract SAXParser.startElement(Unknown Source)

at com.sun.org.apache.xerces.internal.impl.XMLNSDocument ScannerImpl.scanStartElement(Unknown Source)

at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl$NSContentDriver.scanRootElementHook (Unknown Source)

at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(Unknown Source)

at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl$PrologDriver.next(Unknown Source)

at com.sun.org.apache.xerces.internal.impl.XMLDocument ScannerImpl.next(Unknown Source)

at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(Unknown Source)

at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragment ScannerImpl.scanDocument(Unknown Source)

at com.sun.org.apache.xerces.internal.parsers.XML11 Configuration.parse(Unknown Source)

at com.sun.org.apache.xerces.internal.parsers.XML11 Configuration.parse(Unknown Source)

at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(Unknown Source)

at com.sun.org.apache.xerces.internal.parsers. Abstract SAXParser.parse(Unknown Source)

at com.sun.org.apache.xerces.internal.jaxp. SAXParserImpl$JAXPSAXParser.parse(Unknown Source)

at com.sun.org.apache.xerces.internal.jaxp. SAXParserImpl.parse(Unknown Source) at org.eclipse.update.internal.configurator.ConfigurationParser.parse(ConfigurationParser.java:76)

at org.eclipse.update.internal.configurator.PlatformConfiguration. loadConfig(PlatformConfiguration.java:1089)

at org.eclipse.update.internal.configurator.PlatformConfiguration. initializeCurrent(PlatformConfiguration.java:752)

at org.eclipse.update.internal.configurator.PlatformConfiguration.(PlatformConfiguration.java:104)

at org.eclipse.update.internal.configurator.PlatformConfiguration.startup(PlatformConfiguration.java:707)

at org.eclipse.update.internal.configurator.ConfigurationActivator.getPlatformConfiguration (ConfigurationActivator.java:404)

at org.eclipse.update.internal.configurator.Configuration Activator.initialize(Configuration Activator.java:136)

at org.eclipse.update.internal.configurator.ConfigurationActivator.start(Configuration Activator.java:69)

at org.eclinse osoi.framework.internal.core. BundleContext Imo1$1.run(BundleContext Impl.java:783)

at org.eclipse.update.internal.configurator. ConfigurationActivator.initialize(ContigurationActivator.java:136)

at org.eclipse.update.internal.configurator.Configuration Activator.start(Configuration Activator.java:69)

at org.eclipse.osgi.framework.internal.core. BundleContextImpl$1.run(BundleContextImpl.java:783)

at java.security.AccessController.doPrivileged (Native Method)

at org.eclipse.osgi.framework.internal.core. BundleContextImpl.startActivator(BundleContextImpl.java:774)

at org.eclipse.osgi. framework.internal.core. BundleContext Impl.start(BundleContext Impl.java:755)

at org.eclipse.osgi.framework.internal.core. BundleHost.startworker(BundleHost.java:370)

at org.eclipse.osgi. framework.internal.core.AbstractBundle.resume(AbstractBundle.java:374)

at org.eclipse.osgi. framework.internal.core. Framework.resumeBundle(Framework.java:1067) at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles (StartLevelManager.java:561)

at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles (StartLevelManager.java:546)

at org.eclipse.osgi. framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:459)

at org.eclipse.osgi.framework. internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)

at org.eclipse.osgi. framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:440)

at org.eclipse.osgi.framework.eventmgr. EventManager.dispatchEvent(EventManager.java:227)

at org.eclipse.osgi.framework.eventmgr. EventManager $EventThread.run(EventManager.java: 337)

 

!ENTRY org.eclipse.core.runtime 4 0 2022-08-24 18:27:55.135

!MESSAGE

!STACK 0 org.osgi. framework. BundleException: The bundle "org.eclipse.core.runtime_3.6.0.v20100505 [3]" could not be resolved. Reason: Missing Constraint: Require-Bundle: org.eclipse.core.jobs; bundle-version="[3.2.0.4.0.0)"

at org.eclipse.osgi.framework.internal.core. AbstractBundle.getResolverError(AbstractBundle.java:1317)

at org.eclipse.osgi. framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1301)

at org.eclipse.osgi. framework.internal.core. BundleHost.startworker(BundleHost.java:319)

at org.eclipse.osgi.framework.internal.core. Framework.resumeBundle(Framework.java:1067)

at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles (StartLevelManager.java:561)

at org.eclipse.osgi. framework.internal.core.StartLevelManager.resumeBundles (StartLevelManager.java:546)

at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:459)

at org.eclipse.osgi. framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)

at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:440)

at org.eclipse.osgi. framework.eventmgr. EventManager.dispatchEvent(EventManager.java:227)

at org.eclipse.osgi.framework.eventmgr. EventManager $EventThread.run(EventManager.java:337)

 

!ENTRY org.eclipse.osgi 4 0 2022-08-24 18:27:55.135

!MESSAGE Bundle initial@reference: file:plugins/org.eclipse.core.runtime_3.6.0.v20100505.jar/ was not resolved.

!ENTRY org.eclipse.osgi 4 0 2022-08-24 18:27:55.135

!MESSAGE Bundle initial@reference: file:plugins/org.eclipse.equinox.ds_1.2.0.v20100507.jar/ was not resolved.

!ENTRY org.eclipse.osgi 2 0 2022-08-24 18:27:55.151

!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2022-08-24 18:27:55.151

!MESSAGE Bundle initial@reference: file:plugins/org.eclipse.core.runtime_3.6.0.v20100505.jar/ was not resolved.

!SUBENTRY 2 org.eclipse.core.runtime 2 0 2022-08-24 18:27:55.151

MESSAGE Missing required bundle org.eclipse.equinox.registry_[3.4.0,4.0.0).

SUBENTRY 2 org.eclipse.core.runtime 2 0 2022-08-24 18:27:55.151

MESSAGE Missing required bundle org.eclipse.equinox.preferences_[3.3.0, 4.0.0).

SUBENTRY 2 org.eclipse.core.runtime 2 0 2022-08-24 18:27:55.151

MESSAGE Missing required bundle org.eclipse.equinox.app_[1.0.0,2.0.0).

SUBENTRY 2 org.eclipse.core.runtime 2 0 2022-08-24 18:27:55.151

MESSAGE Missing required bundle org.eclipse.core.jobs_[3.2.0.4.0.0).

MESSAGF Missing required bundle org.eclinse.core.contenttvne 13.3.0.4.0.0).

 

!SUBENTRY 2 org.eclipse.core.runtime 2 0 2022-08-24 18:27:55.151

!MESSAGE Missing required bundle org.eclipse.equinox.app_[1.0.0,2.0.0).

! SUBENTRY 2 org.eclipse.core.runtime 2 0 2022-08-24 18:27:55.151

!MESSAGE Missing required bundle org.eclipse.core.jobs_[3.2.0, 4.0.0).

! SUBENTRY 2 org.eclipse.core.runtime 2 0 2022-08-24 18:27:55.151

!MESSAGE Missing required bundle org.eclipse.core.contenttype_[3.3.0.4.0.0).

! SUBENTRY 1 org.eclipse.osgi 2 0 2022-08-24 18:27:55.151

!MESSAGE Bundle initial@reference: file:plugins/org.eclipse.equinox.ds_1.2.0.v20100507.jar/ was not resolved.

! SUBENTRY 2 org.eclipse.equinox.ds 2 0 2022-08-24 18:27:55.151

!MESSAGE Missing imported package org.eclipse. equinox.internal.util.ref_1.0.0.

! SUBENTRY 2 org.eclipse. equinox.ds 2 0 2022-08-24 18:27:55.151

!MESSAGE Missing imported package org.eclipse.equinox.internal.util.timer_1.0.0.

! SUBENTRY 2 org.eclipse.equinox.ds 2 0 2022-08-24 18:27:55.151

!MESSAGE Missing imported package org.eclipse.equinox.internal.util.event_1.0.0.

! SUBENTRY 2 org.eclipse.equinox.ds 2 0 2022-08-24 18:27:55.151

!MESSAGE Missing imported package org.osgi.service.component_1.1.0.

! SUBENTRY 2 org.eclipse.equinox.ds 2 0 2022-08-24 18:27:55.151

!MESSAGE Missing imported package org.eclipse. equinox. internal.util.pool_1.0.0.

! SUBENTRY 2 org.eclipse. equinox.ds 20 2022-08-24 18:27:55.151

!MESSAGE Missing imported package org.eclipse.equinox.internal.util.hash_1.0.0.

! SUBENTRY 2 org.eclipse.equinox.ds 2 0 2022-08-24 18:27:55.151

!MESSAGE Missing imported package org.eclipse.equinox.internal.util.threadpool_1.0.0.

! SUBENTRY 2 org.eclipse.equinox.ds 2 0 2022-08-24 18:27:55.151

!MESSAGE Missing imported package org.osgi.service.log_1.3.0.

! SUBENTRY 2 org.eclipse.equinox.ds 2 0 2022-08-24 18:27:55.151

!MESSAGE Missing imported package org.osgi.service.metatype_1.1.0.

! SUBENTRY 2 org.eclipse.equinox.ds 2 0 2022-08-24 18:27:55.151

!MESSAGE Missing imported package org.osgi.service.cm_1.2.0.

! ENTRY org.eclipse.osgi 2 0 2022-08-24 18:27:55.151

!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:

!SUBENTRY 1 org.eclipse.osgi 2 0 2022-08-24 18:27:55.151

!MESSAGE Bundle org.eclipse.core.runtime_3.6.0.v20100505 [3] was not resolved.

! SUBENTRY 2 org.eclipse.core.runtime 2 0 2022-08-24 18:27:55.151

!MESSAGE Missing required bundle org.eclipse.core.jobs_[3.2.0, 4.0.0).

! SUBENTRY 2 org.eclipse.core.runtime 2 0 2022-08-24 18:27:55.151

!MESSAGE Missing required bundle org.eclipse.equinox.registry_[3.4.0,4.0.0).

! SUBENTRY 2 org.eclipse.core.runtime 2 0 2022-08-24 18:27:55.151

!MESSAGE Missing required bundle org.eclipse.equinox.preferences_[3.3.0.4.0.0).

!SUBENTRY 2 org.eclipse.core.runtime 2 0 2022-08-24 18:27:55.151

!MESSAGE Missing required bundle org.eclipse.core.contenttype_[3.3.0,4.0.0).

! SUBENTRY 2 org.eclipse.core.runtime 2 0 2022-08-24 18:27:55.151

!MESSAGE Missing optionally required bundle org.eclipse.core.runtime.compatibility.auth_[3.2.0,4.0.0).

! SUBENTRY 2 org.eclipse.core.runtime 2 0 2022-08-24 18:27:55.151

!MESSAGE Missing required bundle org.eclipse. equinox.app_[1.0.0,2.0.0).

! SUBENTRY 2 org.eclipse.core.runtime 2 0 2022-08-24 18:27:55.151

!MESSAGE Missing dynamically imported package org.eclipse.core.internal.runtime.auth_0.0.0.

! SUBENTRY 1 org.eclipse.osgi 2 0 2022-08-24 18:27:55.151

!MESSAGE Bundle org.eclipse. equinox.ds_1.2.0.v20100507 [4] was not resolved.

!SUBENTRY 2 org.eclipse.equinox.ds 2 0 2022-08-24 18:27:55.151

!MESSAGE Missing imported package org.eclipse.equinox.internal.util.event_1.0.0.

! SUBENTRY 2 org.eclipse.equinox.ds 2 0 2022-08-24 18:27:55.151

!MESSAGE Missing imported package org.eclipse.equinox.internal.util.hash_1.0.0.

! SUBENTRY ? org.eclinse.pauinox.ds 2 0 2022-08-24 18:27:55.151

 

! SUBENTRY 2 org.eclipse.core.runtime 2 0 2022-08-24 18:27:55.151

!MESSAGE Missing required bundle org.eclipse.core.jobs_[3.2.0, 4.0.0).

! SUBENTRY 2 org.eclipse.core.runtime 2 0 2022-08-24 18:27:55.151

!MESSAGE Missing required bundle org.eclipse.equinox.registry_[3.4.0,4.0.0).

! SUBENTRY 2 org.eclipse.core.runtime 2 0 2022-08-24 18:27:55.151

!MESSAGE Missing required bundle org.eclipse.equinox.preferences_[3.3.0,4.0.0).

! SUBENTRY 2 org.eclipse.core.runtime 2 0 2022-08-24 18:27:55.151

! MESSAGE Missing required bundle org.eclipse.core.contenttype_[3.3.0, 4.0.0).

! SUBENTRY 2 org.eclipse.core.runtime 2 0 2022-08-24 18:27:55.151

!MESSAGE Missing optionally required bundle org.eclipse.core.runtime.compatibility.auth_[3.2.0,4.0.0).

! SUBENTRY 2 org.eclipse.core.runtime 2 0 2022-08-24 18:27:55.151

!MESSAGE Missing required bundle org.eclipse.equinox.app_[1.0.0,2.0.0).

! SUBENTRY 2 org.eclipse.core.runtime 2 0 2022-08-24 18:27:55.151

!MESSAGE Missing dynamically imported package org.eclipse.core.internal.runtime.auth_0.0.0.

! SUBENTRY 1 org.eclipse.osgi 2 0 2022-08-24 18:27:55.151

!MESSAGE Bundle org.eclipse.equinox.ds_1.2.0.v20100507 [4] was not resolved.

! SUBENTRY 2 org.eclipse.equinox.ds 2 0 2022-08-24 18:27:55.151

!MESSAGE Missing imported package org.eclipse.equinox.internal.util.event_1.0.0.

! SUBENTRY 2 org.eclipse.equinox.ds 20 2022-08-24 18:27:55.151

!MESSAGE Missing imported package org.eclipse.equinox.internal.util.hash_1.0.0.

! SUBENTRY 2 org.eclipse.equinox.ds 2 0 2022-08-24 18:27:55.151

!MESSAGE Missing imported package org.eclipse.equinox.internal.util.pool_1.0.0.

! SUBENTRY 2 org.eclipse.equinox.ds 2 0 2022-08-24 18:27:55.151

! MESSAGE Missing imported package org.eclipse. equinox.internal.util.ref_1.0.0.

! SUBENTRY 2 org.eclipse.equinox.ds 2 0 2022-08-24 18:27:55.151

!MESSAGE Missing imported package org.eclipse.equinox.internal.util.threadpool_1.0.0.

! SUBENTRY 2 org.eclipse.equinox.ds 2 0 2022-08-24 18:27:55.151

!MESSAGE Missing imported package org.eclipse.equinox.internal.util.timer_1.0.0.

! SUBENTRY 2 org.eclipse.equinox.ds 2 0 2022-08-24 18:27:55.151

!MESSAGE Missing imported package org.osgi.service.cm_1.2.0.

! SUBENTRY 2 org.eclipse.equinox.ds 2 0 2022-08-24 18:27:55.151

!MESSAGE Missing imported package org.osgi.service.component_1.1.0.

! SUBENTRY 2 org.eclipse.equinox.ds 2 0 2022-08-24 18:27:55.151

!MESSAGE Missing imported package org.osgi.service.log_1.3.0.

! SUBENTRY 2 org.eclipse.equinox.ds 2 0 2022-08-24 18:27:55.151

!MESSAGE Missing imported package org.osgi.service.metatype_1.1.0.

! ENTRY org.eclipse.osgi 4 0 2022-08-24 18:27:55.167

!MESSAGE Application error

! STACK 1

java.lang.IllegalStateException: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini).

 

at org.eclipse.core.runtime. internal. adaptor. EclipseApp Launcher.start(EclipseApp Launcher.java:74)

at org.eclipse.core.runtime. adaptor. EclipseStarter.run(EclipseStarter.java:369)

at org.eclipse.core.runtime. adaptor. EclipseStarter.run(EclipseStarter.java:179)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

at java.lang.reflect.Method.invoke(Unknown Source) at org.eclipse.equinox.launcher.Main.invokeFramework (Main.java:619)

at org.eclipse.equinox.launcher. Main.basicRun(Main.java:574)

at org.eclipse.equinox.launcher. Main.run(Main.java: 1407)

at org.eclipse. equinox.launcher.Main.main(Main.java:1383)

 

Are there any dependencies that I'm missing?

Thank You in advance. 

2 Replies

Avatar

Community Advisor

Hi @rajatkumar,

 

please make sure that this has been installed on your local drive but on not any shared drives (one-drive etc.,) also make sure that the installation directory path should not contain # (pound) and $ (dollar) characters.

Avatar

Level 2

Hi @B_Sravan , it is indeed installed in local drive and for naming convention I have used default directory,
Infact, I tried a fresh installation, still the same results.
install_location.jpg