Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Unable to find newly created users with Admin user

apolu
Level 3
Level 3

Hi AEM Experts,

I am trying to to create new users by using admin privileges, while creating no error/exception ,but when  search with newly created user under /useradmin, i didn't able to see that user but i can able to login with same credentials

I tried to fetch with node structure using query but that is also not showing any results:

SELECT * FROM [nt:base] AS s WHERE ISDESCENDANTNODE([/home/users]) and CONTAINS(s.*, 'test123')

AEM version:

Installed Products
Adobe Experience Manager (6.4.4.0)

Can someone please suggest the next steps here?

Thanks,

Amarnath Polu

1 Accepted Solution
Nirmal_Jose
Correct answer by
Community Advisor
Community Advisor

Hi,

I am able to see the user created without any issues in my local instance.

Screenshot 2019-11-04 at 22.09.45.png

Can you check try creating the user with administrator user itself. If thats working, then its mostly permissions for the user for /home/ path.

If that is not the case, another chance is authorisable index being corrupted. You can reindex it by changing false to true as below

Screenshot+2019-07-08+at+23.16.05.png

Hopefully this helps

View solution in original post

5 Replies
shunnar
Employee
Employee

Try searching with user name instead of first name / last name ?

Nirmal_Jose
Correct answer by
Community Advisor
Community Advisor

Hi,

I am able to see the user created without any issues in my local instance.

Screenshot 2019-11-04 at 22.09.45.png

Can you check try creating the user with administrator user itself. If thats working, then its mostly permissions for the user for /home/ path.

If that is not the case, another chance is authorisable index being corrupted. You can reindex it by changing false to true as below

Screenshot+2019-07-08+at+23.16.05.png

Hopefully this helps

Arun_Patidar
Community Advisor
Community Advisor

The reason you can't see the newly created user because of password policy set, the user will not be created until you will not give password that is in policy. I know there should be propery warning or error message but it is not there at the moment.

AEM Developer Learning : How to set password policy for AEM Users http://www.sgaemsolutions.com/2018/01/custom-sling-model-exporter-in-aem-63.html

apolu
Level 3
Level 3

Hi Nnirmaljosehere

Yes, you are right i found /oak:index/authorizables has been corrupted and re-index resolved my problem.

I am just adding few more proofs, that it shows a column which shown you the date and time as well.

1855373_pastedImage_1.png

Thanks,

Amarnath Polu

stephanieg55925
Level 1
Level 1

The user will need to sign in to the Partner Center with their user name and temporary password Upsers. When the user signs in to the Partner Center for the first time, they are prompted to change their password.