Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Unable to Edit Community Sites

absolute2998726
Level 2
Level 2

Hello,

I have a vanilla OOTB setup of Social Communities.

When trying to save an edited site, I get a 500 error with the following in the error logs

14.02.2018 11:39:08.572 *WARN* [155.201.35.70 [1518626346841] GET /services/tagfilter HTTP/1.1] com.day.cq.wcm.core.impl.components.ComponentCacheImpl No component node found at /services/tagfilter.servlet

14.02.2018 11:39:17.389 *WARN* [155.201.35.70 [1518626357087] POST /content/Community_Site_Name.social.json HTTP/1.1] org.apache.jackrabbit.oak.jcr.delegate.SessionDelegate Attempted to perform refresh while thread Thread-14 was concurrently writing to this session. Blocked until the other thread finished using this session. Please review your code to avoid concurrent use of a session.

14.02.2018 11:39:17.650 *ERROR* [155.201.35.70 [1518626357087] POST /content/Community_Site_Name.social.json HTTP/1.1] com.adobe.cq.social.scf.core.operations.AbstractSocialOperation Error performing operation

com.adobe.cq.social.scf.OperationException: Failed to update community site.

at com.adobe.cq.social.site.endpoints.AbstractSiteOperationService.update(AbstractSiteOperationService.java:414)

at com.adobe.cq.social.site.endpoints.AbstractSiteOperationService.update(AbstractSiteOperationService.java:1292)

at com.adobe.cq.social.site.endpoints.impl.SiteUpdateOperation.performOperation(SiteUpdateOperation.java:89)

at com.adobe.cq.social.scf.core.operations.AbstractSocialOperation.run(AbstractSocialOperation.java:82)

at org.apache.sling.servlets.post.impl.SlingPostServlet.doPost(SlingPostServlet.java:202)

1 Accepted Solution
absolute2998726
Correct answer by
Level 2
Level 2

Was missing group membership to:

social-siteadmin

View solution in original post

1 Reply
absolute2998726
Correct answer by
Level 2
Level 2

Was missing group membership to:

social-siteadmin

View solution in original post