Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

touch ui page not getting refreshed on adding new component

Avatar

Level 2

Hi,

I am adding a touch ui component to the page, but am getting the below js error and the page is not getting refreshed,  so am not able to edit the component. Only when i refresh the page manually am able to edit the component.

editor.js:5633 : Uncaught TypeError: Cannot read property 'getParentPath' of undefined

    at Array.ns.store.self.getParent (http://52.86.19.183:4502/libs/cq/gui/components/authoring/clientlibs/editor.js:5633:41)

    at Object.<anonymous> (http://52.86.19.183:4502/libs/cq/gui/components/authoring/clientlibs/editor.js:18000:47)

    at fire (http://52.86.19.183:4502/etc/clientlibs/granite/jquery.js:3143:30)

    at Object.fireWith [as resolveWith] (http://52.86.19.183:4502/etc/clientlibs/granite/jquery.js:3255:7)

    at Object.deferred.(anonymous function) [as resolve] (http://52.86.19.183:4502/etc/clientlibs/granite/jquery.js:3345:34)

    at http://52.86.19.183:4502/libs/cq/gui/components/authoring/clientlibs/editor.js:26200:104

    at dispatch (http://52.86.19.183:4502/etc/clientlibs/granite/jquery.js:4665:9)

    at elemData.handle (http://52.86.19.183:4502/etc/clientlibs/granite/jquery.js:4333:28)

  I already have the cq:listeners for the components which have the property to refresh the page on adding a new component. Kindly suggest how to fix this js issue.

9 Replies

Avatar

Level 8

First off, I would maybe try a private browser window and make sure it's not a javascript caching issue.

Secondly, I would take a look at your node structure and make sure that the page has a valid cq:template and sling:resourceType.

Avatar

Level 2

Was a component node added to the jcr on that page as a result of dragging the component on to the page?

Also, it might be useful to share some details of your component and/or try stripping out most of the logic out to test out a basic component.

Avatar

Level 10

Paste a screen shot of the component and dialog. Looks like there is an issue with the way its setup. Also - is your component an HTL component? WHat version of AEM are you using?

Avatar

Level 2

I am facing this issue when i drag and drop any of the components in my page. Also the mentioned js error comes up only when  the page under particular hierarchy say "/content/projectname/en-us" , but when the page is under "/content/projectname" am not facing this issue.

Am using HTL component and AEM version is 6.1.

Also i tried removing all the js as well from the template but still the issue persists

Avatar

Administrator

Can you please state the steps to reproduce this?

Any particular component showing this? Can you try it on fresh instance as well ?

~kautuk

Avatar

Level 9

Hi Kritikar,

It looks like you are loading an external library before editor is loaded. Change the order of loading the script.

Thanks,

Avatar

Level 2

I am getting the exact same issue (behaviour and JS error).

AEM 6.2 SP1 - Touch UI