Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

The import info.geometrixx cannot be resolved

Avatar

Not applicable

I am using archetype 10 project. I created a new class file under sample.core project. I am trying to access GeoHelper class by importing below:

import info.geometrixx.commons.util.GeoHelper;

I am getting a notification like below: 

The import info.geometrixx cannot be resolved

How to resolve this issue? How can I import the jar file? 

1 Accepted Solution

Avatar

Correct answer by
Level 10

Just Verifying,

Once you have added this class in eclipse, did you took the build to AEM?

Build is process where these java files gets deployed to AEM using maven as a single jar,

If not take a look at http://www.aemcq5tutorials.com/tutorials/create-osgi-bundle-in-aem/

View solution in original post

4 Replies

Avatar

Level 10

Are you seeing this error when you use this in JSP in component?

Make sure you are exporting the package in which you have added this class.

Avatar

Not applicable

edubey wrote...

Are you seeing this error when you use this in JSP in component?

Make sure you are exporting the package in which you have added this class.

 

How can I export the JAR file and which JAR file should I export? I believe that this project is configured with all the JARs required for the development. Do I need to create a lib folder, add the JAR file and edit pom.xml file?

Avatar

Correct answer by
Level 10

Just Verifying,

Once you have added this class in eclipse, did you took the build to AEM?

Build is process where these java files gets deployed to AEM using maven as a single jar,

If not take a look at http://www.aemcq5tutorials.com/tutorials/create-osgi-bundle-in-aem/

Avatar

Administrator

Hi

Please have a look at this stackoverflow question.

Link:- http://stackoverflow.com/questions/16918959/import-cannot-be-resolved

//Import *** could not be resolved '

 

Solution:-  

Right click on project - >BuildPath - >Configure BuildPath - >Libraries tab - >

Double click on JRE SYSTEM LIBRARY - >Then select alternate JRE

 

If the project is Maven, you can try this way :

  1. right click the "Maven Dependencies"-->"Build Path"-->"Remove from the build path";
  2. right click the project ,navigate to "Maven"--->"Update project....";

Then the import issue should be solved .

Some Reference Forum post:-

Link:- http://help-forums.adobe.com/content/adobeforums/en/experience-manager-forum/adobe-experience-manage...

Link:- http://help-forums.adobe.com/content/adobeforums/en/experience-manager-forum/adobe-experience-manage...

 

I hope this would help you.

 

Thanks and Regards

Kautuk Sahni