SPA with Adobe Target V2 -- Different views are not getting loaded

sreekalyani

26-07-2020

Hi,

I am new to adobe target. I am trying to use Adobe Target with SPA with new at.js 2.0.

So followed the tutorial in https://www.youtube.com/watch?v=deAUBBDYRWQ&t=663s

I have created launch properties in launch i.e page load & start event property

sreekalyani_0-1595759157635.png

 

 

 

and also targeted the pages in Adobe Target.

sreekalyani_1-1595759157642.png

 

I am able to see at.js being loaded in the debugger console.

sreekalyani_2-1595759157648.png

 

But when I am trying to add a custom event to triggerView of Adobe Target, I am always getting the window.location.pathname as the home page and also different views are not getting triggered.

I have used List core component for getting the list of pages. When clicked on the links then different view has to be triggered. But that is not happening.

sreekalyani_3-1595759157651.png

 

 

When I click on employeelist or image content observed that window.location.pathname is always same. i.e.,

sreekalyani_4-1595759157651.png

 

For triggering view in Launch I have used to create a custom event as below

sreekalyani_5-1595759157654.png

 

sreekalyani_6-1595759157660.png

 

And the action type is

sreekalyani_7-1595759157663.png

 

The data element created is as

sreekalyani_8-1595759157665.png

the data element script is

sreekalyani_10-1595759535223.png

 

So why I am not able to trigger different view and window.location.pathname is always home page one.

 

Regards,

Sree

Accepted Solutions (0)