Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SAML integration in AEM not working

Avatar

Level 4

Hi All, 

I am trying to integrate SAML to AEM for this I have followed below Azure article. I have done all the steps. When I try to test the url it throws the below error. can someone help me ??

https://medium.com/adobetech/saml-authentication-in-aem-using-microsoft-azure-active-directory-30d66...

 

Error : 

Tessa_learner1_0-1650531381128.png

 

10 Replies

Avatar

Level 4

Thank you @Arun_Patidar . I have started my aem author instance and it doesn't asking me the credentials directly it took me to the aem admin console. Is this why we are using SAML integration, since I'm new to SAML.

Avatar

Community Advisor

Hi,

SAML is used for SSO, so you can login using external IDP.

is this working as expected?

Avatar

Level 4

@Arun_Patidar  External Idp means which url i need to use, Is it from the Azure (configured for certificate) or adobe ? As of now, I can login to aem author without entering username and password. 

Avatar

Community Advisor

I am not sure which one you are using Adobe IMS or Azure. But if it is working then you can check the user id, what user is created/logged in in AEM to verify that everything is ok.

Avatar

Level 4

Hi @Arun_Patidar  I have used Azure to get the idp certificate. I'm sorry that I'm very new to this SAML integration. I have configured everything in the ConfigMgr as per the guide. But now I don't know how and where to check this saml so it's working correctly or not. As usual I'm logging into AEM author instance by admin username & pwd. Don't know where to exactly check about this feature. Can you just elaborate ? like which link i need to check aem author or azure login id ????

And when I use azure login id it says like below.  Thank you and sorry If I trouble you more.

 

Tessa_learner1_0-1650863868102.png

 

Avatar

Community Advisor

Hi,

You try login in incognito widow using SSO, and check the login works or not.

If you are getting Azure login screen that means you are using Azure IDP

Avatar

Level 4

Hi @Arun_Patidar  Thank you. I have tested in incognito mode. But I got some error like below.  So I checked the error log. It says like Missing AD. Any help would be appreciated .

 

27.04.2022 11:32:00.500 *ERROR* [qtp1765808865-2356] org.apache.felix.metatype Missing element AD in element OCD : bundle://073adf9b-a203-42ab-b792-33c22343dce6_362.1:0/OSGI-INF/metatype/com.day.cq.mailer.oauth.impl.OAuthCodeServiceImpl.xml


27.04.2022 11:32:00.500 *ERROR* [qtp1765808865-2356] org.apache.felix.metatype Missing element AD in element OCD : bundle://073adf9b-a203-42ab-b792-33c22343dce6_362.1:0/OSGI-INF/metatype/com.day.cq.mailer.oauth.impl.OAuthMailerServiceImpl.xml
27.04.2022 11:32:00.500 *ERROR* [qtp1765808865-2356] org.apache.felix.metatype Missing element AD in element OCD : bundle://073adf9b-a203-42ab-b792-33c22343dce6_362.1:0/OSGI-INF/metatype/com.day.cq.mailer.oauth.impl.OAuthTokenStoreServiceImpl.xml
27.04.2022 11:32:00.505 *ERROR* [qtp1765808865-2356] org.apache.felix.metatype Missing element AD in element OCD : bundle://073adf9b-a203-42ab-b792-33c22343dce6_388.1:0/OSGI-INF/metatype/com.adobe.cq.dam.ips.impl.replication.trigger.AssetRestoreEventHandler.xml
27.04.2022 11:32:00.512 *ERROR* [qtp1765808865-2356] org.apache.felix.metatype Missing element AD in element OCD : bundle://073adf9b-a203-42ab-b792-33c22343dce6_424.0:0/OSGI-INF/metatype/com.adobe.social.integrations.livefyre.config.impl.LivefyreConfigProviderImpl.xml

 

Tessa_learner1_0-1651041092776.png