Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Rich Text Editor stripping out href tags.

vijayk87714775
Level 4
Level 4

Hi All , I have gone through all the threads related to the same issue and tried all suggested solutions but problem still exists . 1.RTE is removing href tags when you try to re-open the dialog for the already authored content that has href tags.. 2. Removes href tags  when you try to author for the first time for the content with maximum href's . we are using aem 6.2 sp1 cfp 16 Thanks in advance.

6 Replies
smacdonald2008
Level 10
Level 10

I am opening a dialog in Touch UI and able to enter a link to another site. See.

CNNlink.png

The page responds correctly too.

CNN2.png

How are you adding the link in your instance?

vijayk87714775
Level 4
Level 4

Hi Scott , Thanks for replying  I am adding the links in the same way you did. I have tried on the Geometrixx pages as well and still I was able to see the issue . As you said you were checking with internal people ,any luck there ?

Veena_Vikram
Community Advisor
Community Advisor

Hi Vijay

      I have my server with same configuration . But I don't see this issue

1585786_pastedImage_0.png1585802_pastedImage_0.png

  So the issue you are having is with a custom component ? Can you test the same scenario with any OOTB component and in Geometrixx too ?

Thanks

Veena

smacdonald2008
Level 10
Level 10

Can you try on a fresh instance and see if you get this in a new DEV fresh AEM instance.

senthil86
Level 2
Level 2

@smacdonald2008  We have created custom link and it execute innerhtml properly with href tag.

But while we check in source edit href tag along disappeared if we changed href to href1 then it is persist and save also . Do we want to update any thing in XSS or any configuration .

 

Thanks in advance !