Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

responsive layout old breakpoints are not getting deleted through build

Avatar

Level 3

Hi Team,

Could anyone help me to resolve the below.

 

Have created new break points for responsive layout. After the build can see the newly added breakpoints but old breakpoints are not getting deleted. May I know how to delete it through build.

 

Thanks!

5 Replies

Avatar

Community Advisor

Hi,

Are old break points custom or out of the box ? Try to find from where the old breakpoints are referring from and if they are from out of the box folder, override that path into /apps and empty the file. Make sure the path is included in filter.xml of your code to include in the build.

Avatar

Level 3

Hi @Ravi_Pampana 

yes old breakpoints are OOTB. But have updated this property value cq:deviceGroups as below.

 

cq:deviceGroups="[mobile/groups/responsive]" - old
cq:deviceGroups="[/etc/mobile/groups/archetype]" - new & its having the updated emulator values.

 

emulators="[/apps/adobe/emulators/base,/apps/adobe/emulators/small,/apps/adobe/emulators/medium,/apps/adobe/emulators/large]">

 

Also updated the filter.xml

<filter root="/conf/adobe/settings/wcm/templates/home-content/structure" mode="update"/>

But still both are there. Any inputs please?

 

Thank you

Avatar

Level 3

Tried with mode=replace & include pattern as well. But no luck. Could someone help on this please?

<filter root="/conf/adobe/settings/wcm/templates/home-content/structure" mode="replace">
<include pattern="/conf/adobe/settings/wcm/templates/home-content/structure(/.*)?" />
</filter>

Avatar

Community Advisor

Can you check by unzipping the package and see whether it is having two or only 1. With this we can eliminate whether code is having both values or while installing the code is not getting replaced.

Avatar

Community Advisor

Seems you are using update which will add the new but not removes the old

 

  1. replace : This is the normal behavior. Existing content is replaced completely by the imported content, i.e. is overridden or deleted accordingly.
  2. merge : Existing content is not modified, i.e. only new content is added and none is deleted or modified.
  3. update : Existing content is updated, new content is added and none is deleted.