Replication Queue blocked - Failed to register namespace mapping illustrator

Avatar

Avatar

jerrys49113842

Avatar

jerrys49113842

jerrys49113842

18-12-2015

Hi,

 

AEM 6.1.0

 

We get the following error on some PDF / Images : 

18.12.2015 15:12:12 - ERROR - replication-to-wcm-build-publish : Replication (ACTIVATE) of /content/dam/conseil_etat/fr/actualites/2013/12/CActivit__s_pour_l_ann__e_2012-2013/cs_rapport_annuel_2013_web.pdf not successful. Conversation follows
18.12.2015 15:12:12 - ERROR - replication-to-wcm-build-publish : ------------------------------------------------
18.12.2015 15:12:12 - ERROR - replication-to-wcm-build-publish : Sending message to 148.110.139.141:4503
18.12.2015 15:12:12 - ERROR - replication-to-wcm-build-publish : >> POST /bin/receive HTTP/1.0
18.12.2015 15:12:12 - ERROR - replication-to-wcm-build-publish : >> Action: Activate
18.12.2015 15:12:12 - ERROR - replication-to-wcm-build-publish : >> Path: /content/dam/conseil_etat/fr/actualites/2013/12/CActivit__s_pour_l_ann__e_2012-2013/cs_rapport_annuel_2013_web.pdf
18.12.2015 15:12:12 - ERROR - replication-to-wcm-build-publish : >> Handle: /content/dam/conseil_etat/fr/actualites/2013/12/CActivit__s_pour_l_ann__e_2012-2013/cs_rapport_annuel_2013_web.pdf
18.12.2015 15:12:12 - ERROR - replication-to-wcm-build-publish : >> Referer: about:blank
18.12.2015 15:12:12 - ERROR - replication-to-wcm-build-publish : >> ...spooling 2088099 bytes...
18.12.2015 15:12:12 - ERROR - replication-to-wcm-build-publish : --
18.12.2015 15:12:12 - ERROR - replication-to-wcm-build-publish : << HTTP/1.1 400 Bad Request
18.12.2015 15:12:12 - ERROR - replication-to-wcm-build-publish : << Date: Fri, 18 Dec 2015 14:12:12 GMT
18.12.2015 15:12:12 - ERROR - replication-to-wcm-build-publish : << X-Content-Type-Options: nosniff
18.12.2015 15:12:12 - ERROR - replication-to-wcm-build-publish : << Set-Cookie: cq-authoring-mode=TOUCH;Path=/;Expires=Fri, 25-Dec-2015 14:12:12 GMT
18.12.2015 15:12:12 - ERROR - replication-to-wcm-build-publish : << Expires: Thu, 01 Jan 1970 00:00:00 GMT
18.12.2015 15:12:12 - ERROR - replication-to-wcm-build-publish : << Content-Type: text/plain; charset=UTF-8
18.12.2015 15:12:12 - ERROR - replication-to-wcm-build-publish : << Content-Length: 177
18.12.2015 15:12:12 - ERROR - replication-to-wcm-build-publish : << Server: Jetty(9.2.9.v20150224)
18.12.2015 15:12:12 - ERROR - replication-to-wcm-build-publish : << X-Powered-By: Jetty(9.2.9.v20150224)
18.12.2015 15:12:12 - ERROR - replication-to-wcm-build-publish : << 
18.12.2015 15:12:12 - ERROR - replication-to-wcm-build-publish : << error: com.day.cq.replication.ReplicationException: Repository error during node import: Failed to register namespace mapping illustrator -> http://ns.adobe.com/illustrator/1.0/
18.12.2015 15:12:12 - ERROR - replication-to-wcm-build-publish : Message sent.
18.12.2015 15:12:12 - ERROR - replication-to-wcm-build-publish : ------------------------------------------------

 

 

The error on the publish site is:

18.12.2015 15:19:17.974 *ERROR* [148.110.139.141 [1450448357906] POST /bin/receive HTTP/1.1] com.day.cq.replication.impl.servlets.ReplicationServlet Error during replication: Repository error during node import: Failed to register namespace mapping illustrator -> http://ns.adobe.com/illustrator/1.0/
com.day.cq.replication.ReplicationException: Repository error during node import: Failed to register namespace mapping illustrator -> http://ns.adobe.com/illustrator/1.0/
        at com.day.cq.replication.impl.content.durbo.DurboImporter.createNode(DurboImporter.java:307)
        at com.day.cq.replication.impl.content.durbo.DurboImporter.createNode(DurboImporter.java:215)

...

Caused by: javax.jcr.AccessDeniedException: Failed to register namespace mapping illustrator -> http://ns.adobe.com/illustrator/1.0/
        at org.apache.jackrabbit.oak.api.CommitFailedException.asRepositoryException(CommitFailedException.java:231)

...

Caused by: org.apache.jackrabbit.oak.api.CommitFailedException: OakAccess0000: Access denied
        at org.apache.jackrabbit.oak.security.authorization.permission.PermissionValidator.checkPermissions(PermissionValidator.java:242)
        at org.apache.jackrabbit.oak.security.authorization.permission.PermissionValidator.propertyAdded(PermissionValidator.java:112)

..

 

 

The replication agent has the right to write in /content/dam and it has no problem writing other PDF to that location. 

 

Does anybody have an idea?

 

Thanks in advance,

 

JS

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

kunal23

MVP

Avatar

kunal23

MVP

kunal23
MVP

18-12-2015

These are out of the box namespaces which should already be present on your publish box. It seems there is something wrong with the installation of your publish box as you are saying that you are getting this error for other namespaces as well. Do you get any exceptions when you start your publish instance and have you checked whether all of the OSGI bundles are active on publish? 

Answers (8)

Answers (8)

Avatar

Avatar

jamiec4451712

Avatar

jamiec4451712

jamiec4451712

26-06-2020

Our team recently came across this issue as well.

 

Symptoms:
  • Replication queue stuck and has pending items
  • Replication log shows: error: com.day.cq.replication.ReplicationException: Repository error during node import: Failed to register namespace mapping xmpGImg -> http://ns.adobe.com/xap/1.0/g/img/
Resolution:
  1. Visit the CRX Explorer (https://hostname.or.ip/crx/explorer/index.jsp)
  2. Click "Node Type Administration"
  3. Click "Namespaces"
  4. Add a new namespace
  5. URL: http://ns.adobe.com/xap/1.0/g/img/
  6. Prefix: xmpGImg
  7. Save

 

The replication will now succeed.

Avatar

Avatar

jerrys49113842

Avatar

jerrys49113842

jerrys49113842

21-12-2015

I did install a new standard instance:

cq-publish-p4505.jar 

 

The namespaces are not there. May be the AEM 6.1.0 Jar isn't working correctly?

 

Should I open a ticket with support?

Avatar

Avatar

kunal23

MVP

Avatar

kunal23

MVP

kunal23
MVP

18-12-2015

I guess there are few OSGI bundles missing in your publish instance. OR may be some OOTB content packages are not installed. 

Avatar

Avatar

jerrys49113842

Avatar

jerrys49113842

jerrys49113842

18-12-2015

Thanks for the additional information.

 

Yes all the bundles are started.

 

I compared now the namespaces for the author and the publish and around 15 namespaces are missing:

- most of them are stDim, stFnt, st*...

- all the pdfa*

- pdfxid

- MicrosoftPhoto_1_

- idPriv

 

 

Kind regards

Avatar

Avatar

jerrys49113842

Avatar

jerrys49113842

jerrys49113842

18-12-2015

Thanks Kunal,

 

This seems to be the problem!

I added it and I got a different error that the next namespace is missing.

 

Is there a reason why this happens and how I can disable the check for the namespaces?

Avatar

Avatar

kunal23

MVP

Avatar

kunal23

MVP

kunal23
MVP

18-12-2015

On your publish instance open the nodetypeadmin URL - http://localhost:4503/crx/explorer/nodetypes/index.jsp and click on 'Namespaces'. Check in the list if you can find namespace with "illustrator" prefix registered. If not then click on 'New' button at the bottom and register it manually by entering the URI as "http://ns.adobe.com/illustrator/1.0/" and prefix as "illustrator". 

Avatar

Avatar

jerrys49113842

Avatar

jerrys49113842

jerrys49113842

18-12-2015

The Troubleshooting Replication Page does not give any solution to this problem.

Switched on the debug log. Saw that it seems to fail at creating the metadate node:

....

18.12.2015 16:22:33.504 *DEBUG* [148.110.139.141 [1450452153405] POST /bin/receive HTTP/1.1] com.day.cq.replication.impl.content.durbo.DurboImportTransformer Creating new node /content/dam/conseil_etat/fr/actualites/2013/12/CActivit__s_pour_l_ann__e_2012-2013/cs_rapport_annuel_2013_web.pdf/jcr:content/related/pages/sling:members/page163.pdf with node type: nt:unstructured
18.12.2015 16:22:33.505 *DEBUG* [148.110.139.141 [1450452153405] POST /bin/receive HTTP/1.1] com.day.cq.replication.impl.content.durbo.DurboImportTransformer traversing node /content/dam/conseil_etat/fr/actualites/2013/12/CActivit__s_pour_l_ann__e_2012-2013/cs_rapport_annuel_2013_web.pdf/jcr:content/metadata
18.12.2015 16:22:33.510 *ERROR* [148.110.139.141 [1450452153405] POST /bin/receive HTTP/1.1] com.day.cq.replication.impl.servlets.ReplicationServlet Error during replication: Repository error during node import: Failed to register namespace mapping illustrator -> http://ns.adobe.com/illustrator/1.0/
com.day.cq.replication.ReplicationException: Repository error during node import: Failed to register namespace mapping illustrator -> http://ns.adobe.com/illustrator/1.0/

 

I did a CRX package of the PDF and tried searching for "http://ns.adobe.com/illustrator/1.0/", as i cannot find it at any node (not jcr:node, not metadata, nor any other node)

In the .content.xml of the folder "cs_rapport_annuel_2013_web.pdf", I finally found:

<?xml version="1.0" encoding="UTF-8"?>
<jcr:root xmlns:illustrator="http://ns.adobe.com/illustrator/1.0/" xmlns:pdf="http://ns.adobe.com/pdf/1.3/" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:sling="http://sling.apache.org/jcr/sling/1.0" xmlns:dam="http://www.day.com/dam/1.0" xmlns:cq="http://www.day.com/jcr/cq/1.0" xmlns:jcr="http://www.jcp.org/jcr/1.0" xmlns:mix="http://www.jcp.org/jcr/mix/1.0" xmlns:nt="http://www.jcp.org/jcr/nt/1.0"

I do believe that this seems to do the problem, but how can I fix it? 

For testing purposes, I could upload the package somewhere.

 

 

JS

Avatar

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Answer

2.3K

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Answer

2.3K
smacdonald2008

18-12-2015

See this documentation - it may help: Troubleshooting Replication