Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

References option in AEM content is showing Internal server Error

Avatar

Level 3

Hi,

 

If some user is trying to access some content folders and wanted to check References option in sites.html, they are getting error in references and service is failing.

 

Internal Server Error

Cannot serve request to /mnt/overlay/wcm/core/content/sites/jcr:content/rails/references/items/references.html/content/cs in /libs/wcm/core/components/references/languagecopy/datasources/languageroots/languageroots.jsp

 

Any idea on this ?

 

akhilr48142671_0-1658831512440.png

 

3 Replies

Avatar

Community Advisor

hi @akhilr48142671 

Please check the network logs once post clicking the reference options & also look for any javascript errors. 

Pallavi_Shukla__0-1658833105156.png

 

Avatar

Level 3

Hi @Pallavi_Shukla_ , Thanks but this highlighted network call is 200 for us and there are 2 same calls are triggering with pagename?  and it is giving 500 internal server error like above.

 

It was happening only if we add a specific group to  customers.

As a trial and error while we are checking, we added read permission to /content/usergenerated node for the group.

Then the issue got resolved.

But we are still not clear about the connection between those 

Avatar

Community Advisor

@akhilr48142671 along with trying option mentioned by @Pallavi_Shukla_ , Can you try reindexing OOTB iindexes under /oak:index/?