Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

"Service factory returned null" after AEM migration from 6.0 to 6.3

Avatar

Level 2

Hello experts!

My log is full of "Service factory returned null" errors after migrating AEM 6.0 to 6.3 and updating Java 7 to Java 8.

Here some examples:

879012.12.2017 16:54:24.321 *ERROR* [FelixDispatchQueue] com.day.cq.cq-replication FrameworkEvent ERROR (org.osgi.framework.ServiceException: Service factory returned null. (Component: com.day.cq.replication.impl.OutboxManagerImpl (506)))
895912.12.2017 16:54:24.322 *ERROR* [FelixDispatchQueue] com.day.cq.cq-replication FrameworkEvent ERROR (org.osgi.framework.ServiceException: Service factory returned null. (Component: com.day.cq.replication.impl.transport.RepositoryTransportHandler (507)))

My DS bundle version is:

Version2.1.0.B001
Bundle Locationlaunchpad:/WEB-INF/resources/install/9/org.apache.felix.scr-1.8.2.jar

Seems like a general problem. Do you have any ideas why?

0 Replies

Avatar

Employee

Could you check if all the bundles are up properly?

Avatar

Level 2

Hey thanks for your reply.

Yes all bundles are running. I read here Apache Felix - Users - Service Factory returned null that updating the org.apache.felix.sc bundle resolved the issue. But mine is already up to date.

Avatar

Level 2

I just compared my bundles with the ones of a fresh AEM 6.3 installation and found the following differences:

Missing bundles:

  • com.adobe.cq.screens.com.adobe.cq.screens.sessions AEM Screens - Core (Session Support) 1.2.4
  • com.adobe.cq.core.wcm.components.core Adobe Experience Manager Core WCM Components Core Bundle 1.0.2
  • com.adobe.granite.crypto.file Adobe Granite Crypto Bundle Key Provider 0.0.8
  • com.adobe.granite.crypto.config Adobe Granite Crypto Configuraton 0.0.2
  • com.adobe.granite.jetty.ssl Adobe Granite SSL ContextFactory for Jetty 0.0.14
  • com.adobe.granite.socketio Adobe Granite SocketIO - Core 0.0.6
  • org.apache.felix.http.jetty Apache Felix Http Jetty 3.4.0.B002
  • com.adobe.cq.sample.we.retail.core We.Retail - Core 2.0.2
  • we.retail.client.app.core We.Retail Client App - Core 1.0.14

Version mismatch:

  • org.apache.felix.webconsole.plugins.event Apache Felix Web Console Event Plugin 1.1.4 / 1.1.0

Bundles which are not installed on a fresh installation:

  • com.adobe.granite.installer.patch Adobe Granite Patch Installer 0.0.6
  • com.adobe.cq.social.cq-social-blog AEM Social Communities Blog - Bundle 1.1.7
  • com.adobe.cq.social.cq-social-storage AEM Social Communities Storage - Bundle 1.0.20
  • org.apache.felix.http.bridge Apache Felix Http Bridge 3.0.16
  • biz.aQute.bndlib aQute Bundle Tool Library 1.43.0
  • com.day.cq.cq-activitystreams-api Day Communique 5 Activity Streams API 5.6.2
  • com.day.cq.cq-activitystreams-core Day Communique 5 Activity Streams Core 5.7.4
  • com.day.cq.cq-apns-client Day Communique 5 APNS Client 0.1.6
  • com.day.cq.cq-apns-core Day Communique 5 APNS Core 5.4.0
  • com.day.cq.mcm.cq-mcm-silverpop-integration Day Communique 5 MCM SilverPop Integration 1.1.6
  • com.google.gson Gson 2.3
  • com.day.commons.osgi.wrapper.joda-time joda-time bundle 1.6.0.0002
  • com.day.cq.dam.commons.nekohtml nekohtml bundle 0.9.5

I don't see anything suspicious here though.

Avatar

Level 10

If you build new bundles (using 6.3 dep) - are you seeing this issue

Avatar

Employee

Are you having any UGC reverse replication related configuration in your AEM?

Avatar

Level 10

This issue does not happen on a fresh install. I suspect the issue is related to an upgrade bug. I recommend opening a ticket for this.