Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Publisher crashes down when we run performance test

Avatar

Avatar
Give Back 5
Level 3
minisanu
Level 3

Likes

9 likes

Total Posts

43 posts

Correct Reply

2 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back
Ignite 5
Ignite 3
View profile

Avatar
Give Back 5
Level 3
minisanu
Level 3

Likes

9 likes

Total Posts

43 posts

Correct Reply

2 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back
Ignite 5
Ignite 3
View profile
minisanu
Level 3

30-11-2017

Hi Everyone,

We have one author instance , a load balancer , 2 dispatchers ans 2 publishers. Our code is perfectly fine AEM 6.0 but when we upgraded to AEM 6.2, we could see some performance issues.

Whenever  we run performance test, the publish 2 instance crashes due to heavy load. We could search related queries in logs. That is available in publish 2 not in publish1.None of the search request is going to publish 1. We have disabled link checker configuration and thread dumps are also clean.

What could be the possiblity of having such issues? Please let me know.

   

Your help is greatly appreciated.

Thanks

Yamini

Replies

Avatar

Avatar
Validate 1
Level 10
edubey
Level 10

Likes

273 likes

Total Posts

1,502 posts

Correct Reply

392 solutions
Top badges earned
Validate 1
Give Back 50
Give Back 5
Give Back 3
Give Back 25
View profile

Avatar
Validate 1
Level 10
edubey
Level 10

Likes

273 likes

Total Posts

1,502 posts

Correct Reply

392 solutions
Top badges earned
Validate 1
Give Back 50
Give Back 5
Give Back 3
Give Back 25
View profile
edubey
Level 10

01-12-2017

have you configured indexing for those queries?

Avatar

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,406 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,406 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile
smacdonald2008
Level 10

01-12-2017

I agree with Praveen - this could be an INDEX issue. Have you created an OAK Index?  See - Oak Queries and Indexing

Avatar

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,406 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,406 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile
smacdonald2008
Level 10

01-12-2017

If you have followed the performance docs here:

Performance tuning tips | 6.x

and indexed AEM with OAK INDEXES (one of the points here), then maybe a hotfix is required.

We recommend opening a support ticket so AEM Support Engs can investigate.

Avatar

Avatar
Give Back 5
Level 3
minisanu
Level 3

Likes

9 likes

Total Posts

43 posts

Correct Reply

2 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back
Ignite 5
Ignite 3
View profile

Avatar
Give Back 5
Level 3
minisanu
Level 3

Likes

9 likes

Total Posts

43 posts

Correct Reply

2 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back
Ignite 5
Ignite 3
View profile
minisanu
Level 3

04-12-2017

I have configured Oak indexes already.

Avatar

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,406 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,406 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile
smacdonald2008
Level 10

04-12-2017

This is an upgraded version. You may need a hotfix that addresses performance. I recommend checking with Support.

Avatar

Avatar
Give Back 5
Level 3
minisanu
Level 3

Likes

9 likes

Total Posts

43 posts

Correct Reply

2 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back
Ignite 5
Ignite 3
View profile

Avatar
Give Back 5
Level 3
minisanu
Level 3

Likes

9 likes

Total Posts

43 posts

Correct Reply

2 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back
Ignite 5
Ignite 3
View profile
minisanu
Level 3

04-12-2017

Thanks smacdonald2008. Will check with Support team.