Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Publish Instance Ignoring Query

Avatar

Level 2

Hi All,

I have an odd one...

We recently migrated from our AEM on prem to AEM cloud and have found a bug I'm just not sure how to fix.

We have a component that is using a query to grab articles to display in a carousel. in the Author it looks fine, matches our on prem.. however, when published the publish instance seems to ignore the tag query that filters the articles that should appear in the component and is just grabbing anything in the root. 

 

No Idea why it behaves this way in publish. Any ideas?

1 Accepted Solution

Avatar

Correct answer by
Level 2

Thanks for the help.

The problem seemed to be due to our tag predicates. refined the query to be stricter. Seems to have done the trick. 

After a bit of QueryBuilder Debuggin found the drama and corrected it. 

Thanks again. 

View solution in original post

3 Replies

Avatar

Level 4

Hi @RooRue ,

There are few steps to analyse the query whether it's working or not.
1. Run the query in query debug tool and check if you are finding any hit there.
2. Enable DEBUG logs for QueryBuilder to obtain underlying logs.

3. Check for the indexing in the query performance tool.

 

Most probably you should be able to find the cause for this issue.

Avatar

Correct answer by
Level 2

Thanks for the help.

The problem seemed to be due to our tag predicates. refined the query to be stricter. Seems to have done the trick. 

After a bit of QueryBuilder Debuggin found the drama and corrected it. 

Thanks again.