Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Position the newly created configuration(PageMoveAction) before the standard rollout configuration is not deleting the pages in their old location under live copy on page move.

Avatar

Avatar
Level 1
suprajas4364960
Level 1

Likes

0 likes

Total Posts

4 posts

Correct Reply

0 solutions
View profile

Avatar
Level 1
suprajas4364960
Level 1

Likes

0 likes

Total Posts

4 posts

Correct Reply

0 solutions
View profile
suprajas4364960
Level 1

20-06-2018

Hi,

As per the documentation MSM Best Practices , placing the new configuration before standard rollout configuration is not deleting the pages in the old location of live copy.

To fully realize a page move from a blueprint to live copies, consider the following best practices:

  1. Create a custom rollout configuration:
    • This new configuration must include the action:
      PageMoveAction
      Do not add other actions to this configuration.
  2. Position the new configuration:
    • To fully roll out the page move, while deleting respective pages at their old location in the live copy
      • Position the newly created configuration before the standard rollout configuration.
        The standard rollout configuration will take care of deleting the pages in their old location.

The behavior what we are seeing is :

Let's take a Blueprint website /content/BP with a Livecopy /content/LC

1) Renamed/moved  /content/BP/a/page to /content/BP/a/pageRNM

2)After rollout, both the live copy pages are present /content/LP/a/page and also /content/LP/a/pageRNM .. as per the documentation with PageMoveAction custom rollout placed before standard rollout configuration it should delete the page in the old location( in this case /content/LP/a/page) which is not happening.

Would appreciate any kind of help.

Replies

Avatar

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,406 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,406 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile
smacdonald2008
Level 10

20-06-2018

If you are experiencing a different result then what is documented - there could be a bug. Can you check on another instance of AEM to make sure that this is not a problem that is applicable for your instance. If you see this on another instance - then please open a ticket so this can be fixed.

Avatar

Avatar
Level 1
suprajas4364960
Level 1

Likes

0 likes

Total Posts

4 posts

Correct Reply

0 solutions
View profile

Avatar
Level 1
suprajas4364960
Level 1

Likes

0 likes

Total Posts

4 posts

Correct Reply

0 solutions
View profile
suprajas4364960
Level 1

20-06-2018

The same issue is replicable on "WeRetail" sample site.

Avatar

Avatar
Boost 1
Level 1
AEMDoc
Level 1

Likes

2 likes

Total Posts

4 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
View profile

Avatar
Boost 1
Level 1
AEMDoc
Level 1

Likes

2 likes

Total Posts

4 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
View profile
AEMDoc
Level 1

20-06-2018

Hello suprajas43649601

Could you try to move the pageMoveAction rollout to the top of the list for the rollout configs in the crx/de as well and see if that helps? The final results should look like this

Screen Shot 2018-06-20 at 1.31.08 PM.png

I don't see any information about the version of your AEM but this is working for me in AEM 6.3. If it still didn't help, please share some more details about your setup and configuration.

Avatar

Avatar
Level 1
suprajas4364960
Level 1

Likes

0 likes

Total Posts

4 posts

Correct Reply

0 solutions
View profile

Avatar
Level 1
suprajas4364960
Level 1

Likes

0 likes

Total Posts

4 posts

Correct Reply

0 solutions
View profile
suprajas4364960
Level 1

25-06-2018

Thank you. It is working.

Avatar

Avatar
Validate 1
Level 2
ganthimathir591
Level 2

Like

1 like

Total Posts

18 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 1
Affirm 1
View profile

Avatar
Validate 1
Level 2
ganthimathir591
Level 2

Like

1 like

Total Posts

18 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 1
Affirm 1
View profile
ganthimathir591
Level 2

18-10-2018

Hello suprajas43649601

I am facing the same issue. I maintained the same order of rollout configuration as mentioned by AEM.Doctor​, but the live copies have old pages as well. How did you resolve? Could you help me. Thank you.

Avatar

Avatar
Level 1
andrej_gasteovs
Level 1

Likes

0 likes

Total Posts

1 post

Correct Reply

0 solutions
View profile

Avatar
Level 1
andrej_gasteovs
Level 1

Likes

0 likes

Total Posts

1 post

Correct Reply

0 solutions
View profile
andrej_gasteovs
Level 1

13-05-2019

Hi,

I am still having the same issue on AEM 6.3. PageMoveAction configuration is at the top of the Rollout configuration list and it is placed before Standard Rollout Config in the Blueprint tab in Page Properties. Unfortunately, live copy pages are copied to the new location but they still exist on the old location.

Avatar

Avatar
Boost 1
Level 1
anoopo67696857
Level 1

Like

1 like

Total Posts

3 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
View profile

Avatar
Boost 1
Level 1
anoopo67696857
Level 1

Like

1 like

Total Posts

3 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
View profile
anoopo67696857
Level 1

20-06-2019

Hi,

I am facing the same issue on 6.4..if anyone has the solution do let me know..

Avatar

Avatar
Give Back
Level 1
ryanarb
Level 1

Likes

0 likes

Total Posts

3 posts

Correct Reply

0 solutions
Top badges earned
Give Back
View profile

Avatar
Give Back
Level 1
ryanarb
Level 1

Likes

0 likes

Total Posts

3 posts

Correct Reply

0 solutions
Top badges earned
Give Back
View profile
ryanarb
Level 1

01-02-2021

I am having the same issue on AEM 6.5. I can't even see the list of rollout configs in MiscAdmin as part of restructuring of MSM starting from 6.4. How would it be able to order it in such a way that it is on top of Standard Rollout?