Expand my Community achievements bar.

Enhance your AEM Assets & Boost Your Development: [AEM Gems | June 19, 2024] Improving the Developer Experience with New APIs and Events
SOLVED

passing password having special character in "vlt rcp" command

Avatar

Level 4

Hi all,

 
I am using "vlt rcp" command to copy content from one CRX to another.
http://cq-ops.tumblr.com/post/43179911102/how-to-efficiently-copy-large-amounts-of-content
 
vlt rcp -b 100 -r -u -n http://admin:admin@localhost:4502/crx/-/jcr:root/content/dam/JJK-Folder-1 http://admin:admin@localhost:4503/crx/-/jcr:root/content/dam/JJK-Folder-1
 
My password has special character "@" (for example : admin@123 )
 
So if i use my password in the "vlt rcp" command then it fails (see in bold)
vlt rcp -b 100 -r -u -n http://admin:admin@123@localhost:4502/crx/-/jcr:root/content/dam/JJK-Folder-1 http://admin:admin@123@localhost:4503/crx/-/jcr:root/content/dam/JJK-Folder-1
 
Is there any way to escape special charcater in password or update the above command so that password with special character goes fine.
 
thanks in advance.
1 Accepted Solution

Avatar

Correct answer by
Administrator

Hi rohitspathak123

------------------------------------

Not Sure but you can try

------------------------------------

You can try %encoding while creating the command.

Eg. let say for "admin@123" we could write admin%40123. //@ has hex value of 40 so we escaped it as %40. This is the technique use by many browsers for handling Unicode characters.

 

Thanks and Regards

Kautuk Sahni



Kautuk Sahni

View solution in original post

2 Replies

Avatar

Correct answer by
Administrator

Hi rohitspathak123

------------------------------------

Not Sure but you can try

------------------------------------

You can try %encoding while creating the command.

Eg. let say for "admin@123" we could write admin%40123. //@ has hex value of 40 so we escaped it as %40. This is the technique use by many browsers for handling Unicode characters.

 

Thanks and Regards

Kautuk Sahni



Kautuk Sahni

Avatar

Level 4

Hi Kautuk,

Awsome !

Thanks so much for your quick reply. Yes it worked. I am now able to successfully run the command after replacing "@" by "%40".