Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Page Publish from page editor provides child page references which show as undefined

Ashish-Ranjan
Level 1
Level 1

As per Adobe documentation https://experienceleague.adobe.com/docs/experience-manager-65/authoring/authoring/publishing-pages.h... it says that "Publishing from the editor is a shallow publish, i.e. only the selected page/pages is/are published and any child pages are not." . However in AEM 6.5.4 we are getting child pages and any page comes under undefined.

 

Screenshot 2021-01-07 at 11.30.45 AM.png

 

Is there any quick fix available other than overlay of /libs/cq/gui/components/siteadmin/admin/publishwizard/references/references.jsp . Any documentation providing details on what all comes as references through ActivationReferenceSearchServlet would be helpful.

3 Replies
Vijayalakshmi_S
Community Advisor
Community Advisor

Hi @Ashish-Ranjan,

Can you share the exact snapshot of "undefined" item that is part of the response or share the response object of "undefined" item alone (Shared screenshot highlights the items that are displayed fine)

Also, do high level check on contents of the page. (Example : see if you have Experience or content fragments authored as part of the page.)

Ashish-Ranjan
Level 1
Level 1

Hi @Vijayalakshmi_S

If you see in the screenshot the JSON response with type=page get added under undefined because they are not handled. Also is it correct to get the type=page in the references?

Thanks & Regards

Ashish

Vijayalakshmi_S
Community Advisor
Community Advisor

Getting now. In "/libs/cq/gui/components/siteadmin/admin/publishwizard/references/references.jsp", category named "All pages" is not defined in JSON object unlike stuffs like "All Assets" etc.

ActivationReferenceSearchServlet makes use of ReferenceProvider's findReferences method and the implementation is hidden. - https://helpx.adobe.com/experience-manager/6-3/sites/developing/using/reference-materials/javadoc/co...

 

Am suspecting it to be AEM instance version specific issue.(6.5.4) To affirm the same, can you try once in fresh vanilla instance. Could see that you are trying on we-retail pages only. Just in thought to be sure of fresh instance.

Note : I tried in AEM 6.5.0