Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Page activation(using siteadmin) is too long

Avatar

Level 3

Hi,

I have page with a lot amoun of content. After activation button is pressed ,loading bar is shown for a 2-3 mins, activation response is pending for a 2-3 mins.

[img]http://i.stack.imgur.com/cWYhk.png[/img]

If i use curl command :

curl -u admin:admin -F cmd=activate -F ignoredeactivated=false -F onlymodified=false -F path=/path/topage http://server:port//etc/replication/treeactivation.html

Or 

http://server:port/etc/replication/treeactivation.html

Page will be activated in a few mills.

If I use sidekick to activate page - page activation is too long
as on siteadmin

[img]http://i.stack.imgur.com/N1rZ8.png[/img]

How to fix long activation?

1 Accepted Solution

Avatar

Correct answer by
Level 3

from the screen you posted. it doesn't look like a replication problem (replicate.json is loading quickly). your code is performing some pre-replication operations. and that is taking time. can you check the code that handles the request "preActivateValidator.ht.." and see whats there.

View solution in original post

0 Replies

Avatar

Employee

Hi there,

Thanks for reaching out to Adobe Community.

This could be possible because Replication Queue stuck issue. Please see the below doc to troubleshoot:

https://helpx.adobe.com/experience-manager/kb/replication-stuck.html

Thanks!

Avatar

Correct answer by
Level 3

from the screen you posted. it doesn't look like a replication problem (replicate.json is loading quickly). your code is performing some pre-replication operations. and that is taking time. can you check the code that handles the request "preActivateValidator.ht.." and see whats there.

Avatar

Level 3

There was used some long-runned XPATH queries, I just have substituted them with SQL2 query. Now preActivateValidaror exetutes for a 500ms.

Avatar

Level 3

Hi, I have no any Replication Queue, there is no pages in queue to be activated. Loading bar is appeared before  page activation enters queue

Thanks.