Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Package is duplicated in reactor error

AtulSingh
Level 2
Level 2
Hi !
I am trying to build & deploy a project to AEM using Maven and when I run install command
mvn clean install -PautoInstallSinglePackage
I get below error:
Project 'com.adobe.aem.guides.wknd:aem-guides-wknd.ui.frontend:0.0.1-SNAPSHOT' is duplicated in the reactor
AtulSingh_0-1616007661567.png

 

I tried changing groupId, artifactId & version but still same error.
Any idea how can I resolve this ?
1 Accepted Solution
Arun_Patidar
Correct answer by
Community Advisor
Community Advisor

Hi,

I downloaded the project fromhttps://github.com/adobe/aem-guides-wknd and ran the 

mvn clean install -PautoInstallSinglePackage

I did not see this error 

I execute this command from the project root folder multiple times, did not see error any of the time.

 

[INFO] ------------------------------------------------------------------------

[INFO] Reactor Summary for WKND Sites Project - Reactor Project 0.2.1-SNAPSHOT:

[INFO]

[INFO] WKND Sites Project - Reactor Project ............... SUCCESS [  1.645 s]

[INFO] WKND Sites Project - Core .......................... SUCCESS [ 16.750 s]

[INFO] WKND Sites Project - UI Frontend ................... SUCCESS [ 46.513 s]

[INFO] WKND Sites Project - UI apps structure ............. SUCCESS [  1.514 s]

[INFO] WKND Sites Project - UI apps ....................... SUCCESS [  6.073 s]

[INFO] WKND Sites Project - UI content .................... SUCCESS [  2.549 s]

[INFO] WKND Sites Project - UI config ..................... SUCCESS [  0.251 s]

[INFO] WKND Sites Project - UI sample content ............. SUCCESS [  6.528 s]

[INFO] WKND Sites Project - All ........................... SUCCESS [  7.751 s]

[INFO] WKND Sites Project - Integration Tests ............. SUCCESS [ 29.973 s]

[INFO] WKND Sites Project - Dispatcher .................... SUCCESS [  0.403 s]

[INFO] WKND Sites Project - UI Tests ...................... SUCCESS [  1.553 s]

[INFO] ------------------------------------------------------------------------

[INFO] BUILD SUCCESS

[INFO] ------------------------------------------------------------------------

[INFO] Total time:  02:12 min

[INFO] Finished at: 2021-03-18T13:52:26+01:00

[INFO] ------------------------------------------------------------------------

View solution in original post

0 Replies
Arun_Patidar
Correct answer by
Community Advisor
Community Advisor

Hi,

I downloaded the project fromhttps://github.com/adobe/aem-guides-wknd and ran the 

mvn clean install -PautoInstallSinglePackage

I did not see this error 

I execute this command from the project root folder multiple times, did not see error any of the time.

 

[INFO] ------------------------------------------------------------------------

[INFO] Reactor Summary for WKND Sites Project - Reactor Project 0.2.1-SNAPSHOT:

[INFO]

[INFO] WKND Sites Project - Reactor Project ............... SUCCESS [  1.645 s]

[INFO] WKND Sites Project - Core .......................... SUCCESS [ 16.750 s]

[INFO] WKND Sites Project - UI Frontend ................... SUCCESS [ 46.513 s]

[INFO] WKND Sites Project - UI apps structure ............. SUCCESS [  1.514 s]

[INFO] WKND Sites Project - UI apps ....................... SUCCESS [  6.073 s]

[INFO] WKND Sites Project - UI content .................... SUCCESS [  2.549 s]

[INFO] WKND Sites Project - UI config ..................... SUCCESS [  0.251 s]

[INFO] WKND Sites Project - UI sample content ............. SUCCESS [  6.528 s]

[INFO] WKND Sites Project - All ........................... SUCCESS [  7.751 s]

[INFO] WKND Sites Project - Integration Tests ............. SUCCESS [ 29.973 s]

[INFO] WKND Sites Project - Dispatcher .................... SUCCESS [  0.403 s]

[INFO] WKND Sites Project - UI Tests ...................... SUCCESS [  1.553 s]

[INFO] ------------------------------------------------------------------------

[INFO] BUILD SUCCESS

[INFO] ------------------------------------------------------------------------

[INFO] Total time:  02:12 min

[INFO] Finished at: 2021-03-18T13:52:26+01:00

[INFO] ------------------------------------------------------------------------

View solution in original post

AtulSingh
Level 2
Level 2

I was actually using below command to create the project:
mvn org.apache.maven.plugins:maven-archetype-plugin:2.4:generate -B -DarchetypeGroupId=com.adobe.aem -DarchetypeArtifactId=aem-project-archetype -DarchetypeVersion=25 -DappTitle="WKND Sites Project" -DappId="wknd" -DgroupId="com.adobe.aem.guides.wknd" -DartifactId="aem-guides-wknd" -Dversion="0.0.1-SNAPSHOT" -DaemVersion="cloud"

 

But seems like there is difference in the project downloaded automatically vs Git project link. When we generate project, not all the modules of project gets created hence pop.xml mis-matches.

 

Thanks.

Nikhil-Kumar
Community Advisor
Community Advisor

@AtulSingh -  Can you try doing mvn clean alone once ?


Thanks,
Nikhil

adityas31531516
Level 1
Level 1
Project 'com.mysite:mysite.ui.frontend:1.0.0-SNAPSHOT' is duplicated in the reactor - I am still getting this error @Nikhil-Kumar, even after trying mvn clean once