Expand my Community achievements bar.

Outdated Content fragment while publishing the page

Avatar

Level 2

Hello All,

 

I'm fetching the fields of content fragment at the component level, after authoring the content fragment path in authoring dialog and whenever I'm publishing the page, Its always showing as content fragment model as outdated. Even though content fragment is published already and doesn't have any new changes. 

Any help here would be appreciated.

 

Thanks in Advance!

 

13 Replies

Avatar

Community Advisor

Hi @priyak 
Is it the model or the content fragment itself shown as outdated?



Arun Patidar

Avatar

Community Advisor

could you please check the replication date of content fragment model?



Arun Patidar

Avatar

Level 2

its showing the current time as I published it again now.

Avatar

Community Advisor

@priyak  any thing in logs that you see while you publish the content fragment or on the page load ? 

Avatar

Community Advisor

@priyak  Are you creating the content fragments at right place ?

 

You should have created your Model under a project folder (by default creating a Model at the root folder is disabled). You have to be in a folder with the same name in Assets in order to use your Models. Here is an example of what I mean (using We.Retail): Refer to below URL which might help you 

 

 

https://experienceleaguecommunities.adobe.com/t5/adobe-experience-manager/published-content-fragment...

 

Avatar

Level 2

Yeah content fragment is created at the correct place. I'm able to fetch the fields as well. My only query is whenever I'm publishing the page, content fragment model is showing as outdated, even though I publish the content fragment just now and when I publish my page, it again shows as content fragment model is outdated.

Avatar

Community Advisor

@priyak  Then its a surprise their should be some project specific issue then. Once try below solutions once 

 

  1. Go to the content fragment model in AEM and check if there are any warnings or indications that it is outdated. If so, follow the prompts to update the model. This usually involves reviewing and applying changes to ensure that it reflects the current structure and content of the associated content fragment.

  2. After updating the model, make sure to publish it to ensure that the changes are reflected in the published pages.

Avatar

Level 2

@Jagadeesh_Prakash yeah it seems strange, as replication time is also showing correctly.

And as you suggested, I have verified my CFM and there are no warnings or indications.

Avatar

Community Advisor

@priyak  We are missing some thing here. As per the statements that you mentioned above there is not much that you have done. It's just that you followed very simple steps. But still you are getting this error. 

 

My suggestion would be to try the same in a veenila instance. Expecting that you project code is messing up your CFM

Avatar

Level 2

@Jagadeesh_Prakash yeah you are correct, its not showing as CFM is outdated in vanilla instance. 

But I wonder how my project code is affecting the CFM.

Avatar

Administrator

@priyak Did you find the suggestions from users helpful? Please let us know if more information is required. Otherwise, please mark the answer as correct for posterity. If you have found out solution yourself, please share it with the community.



Kautuk Sahni