Expand my Community achievements bar.

Dive into Adobe Summit 2024! Explore curated list of AEM sessions & labs, register, connect with experts, ask questions, engage, and share insights. Don't miss the excitement.
SOLVED

OSGI Bundle get stopped after hitting url

Avatar

Level 2

Hi All,

Whenever I hit the URL 

http://127.0.0.1:4502/etc/replication/agents.publish.json

My bundle get automatically goes to resolved status from active.

this happened only when i access through ip address .

does any one having same issue.

 

I checked error.log but it is not showing any information.

 

1 Accepted Solution

Avatar

Correct answer by
Employee Advisor

I don't think that this call is the reason that any bundle gets non-active. While this is technically possible to do, I have yet to see code, which does that for a reason.

The only exception is the Bundle Disabler by ACS AEM Commons (https://adobe-consulting-services.github.io/acs-aem-commons/features/osgi-disablers/bundle-disabler/...), but if you configure that one, it will immediate deactivate a bundle as soon as you have activated it.

Please check the logs to get a better impression of the timing, because if a bundle is deactivated you should see a log message.

View solution in original post

6 Replies

Avatar

Community Advisor

Hi @test566 ,

 

Which bundle is going to resolved state? Do you have any custom servlet/service in your system which uses/invokes replication agent programmatically.

 

Thanks,

Ritesh Mittal

Avatar

Level 2

Hi @Ritesh_Mittal ,

Project core bundle

we have 40+ custom servlet having 

resourceTypes = NameConstants.NT_PAGE

but  no servlet  which handled replication agent .

Avatar

Community Advisor

Hi @test566 ,

 

Just try to stop/start the bundle and watch the logs while starting.

 

Thanks,

Ritesh Mittal

Avatar

Level 2

Hi @Ritesh_Mittal ,

already gone through the logs and there is no error regarding that 

 

Avatar

Community Advisor

@test566 I tried this in my local instance and its working fine. Issue could be from your project code. Once try on vineela instance. 

 

But point to worry is "this happened only when i access through ip address ." I am not sure how is this happening only on ip address.

Avatar

Correct answer by
Employee Advisor

I don't think that this call is the reason that any bundle gets non-active. While this is technically possible to do, I have yet to see code, which does that for a reason.

The only exception is the Bundle Disabler by ACS AEM Commons (https://adobe-consulting-services.github.io/acs-aem-commons/features/osgi-disablers/bundle-disabler/...), but if you configure that one, it will immediate deactivate a bundle as soon as you have activated it.

Please check the logs to get a better impression of the timing, because if a bundle is deactivated you should see a log message.