Highlighted

org.apache.jackrabbit.webdav.client.methods,version=[1.0,2) -- Cannot be resolved

umamaheswariy46

19-06-2019

Hi Team,

I am trying to install recap package and having this dependency problem. I have tried installing all the versions of jackrabbit-WebDAV bundles but no use even though I have this available in the console

Exported Packagesorg.apache.jackrabbit.webdav,version=1.1.0
org.apache.jackrabbit.webdav.bind,version=1.0.0
org.apache.jackrabbit.webdav.client.methods,version=2.0.0

Please, any pointers on how to resolve this.

Thanks

Replies

Highlighted

umamaheswariy46

19-06-2019

I am using dependency finder and it returning

<dependency> <artifactId>jackrabbit-webdav</artifactId> <version>2.16.3</version> <groupId>org.apache.jackrabbit</groupId> <scope>provided</scope> </dependency>

this specific jar already available in my console.

Thanks

Highlighted

Jörg_Hoh

Employee

19-06-2019

In the headline of this post it's stated, that the bundle is requesting the java package in a version equal or higher than 1.0 and lower than 2.

If in your AEM instance this package is only exported with the version 2.0, this requirement is not fulfilled.

Most likely the recap bundle does not support the AEM version you are using.

Jörg